<!DOCTYPE html>
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<head><meta charset="UTF-8" />
<script src="/cdn-cgi/apps/head/1A0EzwKI42LNED2YhGMFOvfir40.js"></script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=192-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=192-0&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=192-0&cb=5', false, [], true, false, true, false);</script>
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<link rel="pingback" href="https://b-townblog.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->
<script type="65e35b82932051ca2ab488f3-text/javascript">
		document.documentElement.className = 'js';
	</script>
<script type="65e35b82932051ca2ab488f3-text/javascript">var et_site_url='https://b-townblog.com';var et_post_id='150257';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script>

<title>Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released - The B-Town (Burien) Blog</title>
<meta name="description" content="Burien Police / King County Sheriff&#039;s Office are reporting that they detained three people involved in a recent mail theft in the 16500 block of Maplewild Ave" />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/" />
<meta property="og:locale" content="en_US">
<meta property="og:type" content="article">
<meta property="og:title" content="Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released - The B-Town (Burien) Blog">
<meta property="og:description" content="Burien Police / King County Sheriff&#039;s Office are reporting that they detained three people involved in a recent mail theft in the 16500 block of Maplewild Ave">
<meta property="og:url" content="https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/">
<meta property="og:site_name" content="The B-Town (Burien) Blog">
<meta property="article:publisher" content="https://www.facebook.com/btownblog/">
<meta property="article:tag" content="Burien">
<meta property="article:tag" content="burien police department">
<meta property="article:tag" content="COVID-19">
<meta property="article:tag" content="crime">
<meta property="article:tag" content="king county sherff&#039;s office">
<meta property="article:tag" content="mail">
<meta property="article:tag" content="mail theft">
<meta property="article:tag" content="news">
<meta property="article:tag" content="postal service">
<meta property="article:tag" content="theft">
<meta property="article:tag" content="Three Tree Point">
<meta property="article:tag" content="US Postal Service">
<meta property="article:section" content="Burien">
<meta property="og:image" content="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/uploads/2020/12/BTB-BurienPoliceLogo2020.jpg">
<meta property="og:image:secure_url" content="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/uploads/2020/12/BTB-BurienPoliceLogo2020.jpg">
<meta property="og:image:width" content="1280">
<meta property="og:image:height" content="640">
<meta property="og:image:alt" content="Burien Police">
<meta property="og:image:type" content="image/jpeg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released - The B-Town (Burien) Blog">
<meta name="twitter:description" content="Burien Police / King County Sheriff&#039;s Office are reporting that they detained three people involved in a recent mail theft in the 16500 block of Maplewild Ave">
<meta name="twitter:site" content="@btownblog">
<meta name="twitter:creator" content="@btownblog">
<meta name="twitter:image" content="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/uploads/2020/12/BTB-BurienPoliceLogo2020.jpg">
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":"Place","@id":"https://b-townblog.com/#place"},{"@type":["LocalBusiness","Organization"],"@id":"https://b-townblog.com/#organization","name":"South King Media","url":"https://b-townblog.com","logo":{"@type":"ImageObject","url":"https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/uploads/2019/08/btown_logo.png"},"openingHours":["Monday,Tuesday,Wednesday,Thursday,Friday,Saturday,Sunday 09:00-17:00"],"location":{"@id":"https://b-townblog.com/#place"},"image":{"@type":"ImageObject","url":"https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/uploads/2019/08/btown_logo.png"}},{"@type":"WebSite","@id":"https://b-townblog.com/#website","url":"https://b-townblog.com","name":"South King Media","publisher":{"@id":"https://b-townblog.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/#primaryImage","url":"https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/uploads/2020/12/BTB-BurienPoliceLogo2020.jpg","width":"1280","height":"640"},{"@type":"BreadcrumbList","@id":"https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/#breadcrumb","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"https://b-townblog.com","name":"Home"}},{"@type":"ListItem","position":"2","item":{"@id":"https://b-townblog.com/category/burien/","name":"Burien"}},{"@type":"ListItem","position":"3","item":{"@id":"https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/","name":"Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released"}}]},{"@type":"WebPage","@id":"https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/#webpage","url":"https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/","name":"Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released - The B-Town (Burien) Blog","datePublished":"2021-03-03T13:24:01-08:00","dateModified":"2021-03-03T13:24:01-08:00","isPartOf":{"@id":"https://b-townblog.com/#website"},"primaryImageOfPage":{"@id":"https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/#primaryImage"},"inLanguage":"en-US","breadcrumb":{"@id":"https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/#breadcrumb"}},{"@type":"NewsArticle","headline":"Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released - The","datePublished":"2021-03-03T13:24:01-08:00","dateModified":"2021-03-03T13:24:01-08:00","author":{"@type":"Person","name":"Scott Schaefer"},"publisher":{"@id":"https://b-townblog.com/#organization"},"description":"Burien Police / King County Sheriff&#039;s Office are reporting that they detained three people involved in a recent mail theft in the 16500 block of Maplewild Ave","@id":"https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/#richSnippet","isPartOf":{"@id":"https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/#webpage"},"image":{"@id":"https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/#primaryImage"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/#webpage"}}]}</script>

<link rel='dns-prefetch' href='//cdn.broadstreetads.com' />
<link rel='dns-prefetch' href='//clientcdn.pushengage.com' />
<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The B-Town (Burien) Blog &raquo; Feed" href="https://b-townblog.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The B-Town (Burien) Blog &raquo; Comments Feed" href="https://b-townblog.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="The B-Town (Burien) Blog &raquo; iCal Feed" href="https://b-townblog.com/events/?ical=1" />
<script type="65e35b82932051ca2ab488f3-text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/b-townblog.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<meta content="Extra v.4.9.0" name="generator" /><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='tribe-common-skeleton-style-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css?ver=4.12.18' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-tooltip-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css?ver=4.12.18' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-block-style-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/social-icons-widget-by-wpzoom/block/dist/blocks.style.build.css?ver=1611178814' type='text/css' media='all' />
<style id="wpb-google-fonts-css" media="all">@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 400;
  src: url(/fonts.gstatic.com/s/opensans/v18/mem8YaGs126MiZpBA-UFVZ0e.ttf) format('truetype');
}
</style>
<link rel='stylesheet' id='weather-atlas-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/weather-atlas/public/css/weather-atlas-public.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/weather-atlas/public/font/weather-icons/weather-icons.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.2.4' type='text/css' media='all' />
<style id="extra-fonts-css" media="all">@font-face {
  font-family: 'Open Sans';
  font-style: italic;
  font-weight: 300;
  src: url(/fonts.gstatic.com/s/opensans/v18/memnYaGs126MiZpBA-UFUKWyV9hlIqY.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans';
  font-style: italic;
  font-weight: 400;
  src: url(/fonts.gstatic.com/s/opensans/v18/mem6YaGs126MiZpBA-UFUK0Xdcg.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans';
  font-style: italic;
  font-weight: 600;
  src: url(/fonts.gstatic.com/s/opensans/v18/memnYaGs126MiZpBA-UFUKXGUdhlIqY.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans';
  font-style: italic;
  font-weight: 700;
  src: url(/fonts.gstatic.com/s/opensans/v18/memnYaGs126MiZpBA-UFUKWiUNhlIqY.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans';
  font-style: italic;
  font-weight: 800;
  src: url(/fonts.gstatic.com/s/opensans/v18/memnYaGs126MiZpBA-UFUKW-U9hlIqY.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 300;
  src: url(/fonts.gstatic.com/s/opensans/v18/mem5YaGs126MiZpBA-UN_r8OXOhs.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 400;
  src: url(/fonts.gstatic.com/s/opensans/v18/mem8YaGs126MiZpBA-UFW50e.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 600;
  src: url(/fonts.gstatic.com/s/opensans/v18/mem5YaGs126MiZpBA-UNirkOXOhs.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 700;
  src: url(/fonts.gstatic.com/s/opensans/v18/mem5YaGs126MiZpBA-UN7rgOXOhs.ttf) format('truetype');
}
@font-face {
  font-family: 'Open Sans';
  font-style: normal;
  font-weight: 800;
  src: url(/fonts.gstatic.com/s/opensans/v18/mem5YaGs126MiZpBA-UN8rsOXOhs.ttf) format('truetype');
}
</style>
<link rel='stylesheet' id='extra-style-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/themes/Extra/style.css?ver=4.9.0' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-socicon-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/wpzoom-socicon.css?ver=1611178814' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-genericons-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/genericons.css?ver=1611178814' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-academicons-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/academicons.min.css?ver=1611178814' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-font-awesome-3-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/font-awesome-3.min.css?ver=1611178814' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/css/dashicons.min.css?ver=5.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-social-icons-styles-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/css/wpzoom-social-icons-styles.css?ver=1611178814' type='text/css' media='all' />
<link rel="preload" as="font" id='wpzoom-social-icons-font-academicons-ttf-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.ttf?v=1.8.6' type='text/css' type="font/ttf" crossorigin />
<link rel="preload" as="font" id='wpzoom-social-icons-font-academicons-woff-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/academicons.woff?v=1.8.6' type='text/css' type="font/woff" crossorigin />
<link rel="preload" as="font" id='wpzoom-social-icons-font-fontawesome-3-ttf-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.ttf?v=4.7.0' type='text/css' type="font/ttf" crossorigin />
<link rel="preload" as="font" id='wpzoom-social-icons-font-fontawesome-3-woff-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff?v=4.7.0' type='text/css' type="font/woff" crossorigin />
<link rel="preload" as="font" id='wpzoom-social-icons-font-fontawesome-3-woff2-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/fontawesome-webfont.woff2?v=4.7.0' type='text/css' type="font/woff2" crossorigin />
<link rel="preload" as="font" id='wpzoom-social-icons-font-genericons-ttf-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.ttf' type='text/css' type="font/ttf" crossorigin />
<link rel="preload" as="font" id='wpzoom-social-icons-font-genericons-woff-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/Genericons.woff' type='text/css' type="font/woff" crossorigin />
<link rel="preload" as="font" id='wpzoom-social-icons-font-socicon-ttf-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.ttf' type='text/css' type="font/ttf" crossorigin />
<link rel="preload" as="font" id='wpzoom-social-icons-font-socicon-woff-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/font/socicon.woff' type='text/css' type="font/woff" crossorigin />
<script type='text/javascript' data-cfasync='false' src='//cdn.broadstreetads.com/init-2.min.js?ver=5.6.2' id='broadstreet-cdn-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/weather-atlas/public/js/weather-atlas-public.min.js?ver=1.2.1' id='weather-atlas-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/weather-atlas/public/js/jquery-cookie.min.js?ver=1.2.1' id='jquery-cookie-js'></script>
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/b-townblog.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":150257,"token":"ccefdbcd63","lang":0,"debug":0}
</script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.2.4' id='wpp-js-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://www.googletagmanager.com/gtag/js?id=UA-6242924-1' id='google_gtagjs-js' async></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["b-townblog.com"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-6242924-1", {"anonymize_ip":true});
</script>
<link rel="https://api.w.org/" href="https://b-townblog.com/wp-json/" /><link rel="alternate" type="application/json" href="https://b-townblog.com/wp-json/wp/v2/posts/150257" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://b-townblog.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://b-townblog.com/?p=150257' />
<link rel="alternate" type="application/json+oembed" href="https://b-townblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fb-townblog.com%2F2021%2F03%2F03%2Fburien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://b-townblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fb-townblog.com%2F2021%2F03%2F03%2Fburien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.27.0" /><link href="https://trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<link href="https://vd.trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://b-townblog.com"><link rel="https://theeventscalendar.com/" href="https://b-townblog.com/wp-json/tribe/events/v1/" /><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><link rel="shortcut icon" href="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/uploads/2020/09/BTBFavicon2.jpg" /><link rel="preload" href="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/themes/Extra/core/admin/fonts/modules.ttf" as="font" crossorigin="anonymous"><link rel="amphtml" href="https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/amp/"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" type="65e35b82932051ca2ab488f3-text/javascript"></script><script type="65e35b82932051ca2ab488f3-text/javascript">(adsbygoogle = window.adsbygoogle || []).push({"google_ad_client":"ca-pub-2062216921302425","enable_page_level_ads":true,"tag_partner":"site_kit"});</script>
<script type="65e35b82932051ca2ab488f3-text/javascript">
( function( w, d, s, l, i ) {
	w[l] = w[l] || [];
	w[l].push( {'gtm.start': new Date().getTime(), event: 'gtm.js'} );
	var f = d.getElementsByTagName( s )[0],
		j = d.createElement( s ), dl = l != 'dataLayer' ? '&l=' + l : '';
	j.async = true;
	j.src = 'https://www.googletagmanager.com/gtm.js?id=' + i + dl;
	f.parentNode.insertBefore( j, f );
} )( window, document, 'script', 'dataLayer', 'GTM-W3XBHN9' );
</script>

<meta name="msvalidate.01" content="7E1E96B84AE8370D63E4DCDCA37E5772">
<script type="65e35b82932051ca2ab488f3-text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-W3XBHN9');</script>

<script type="65e35b82932051ca2ab488f3-text/javascript">
var year = new Date();
year = year.getFullYear();
jQuery(function($){
	$('#footer-info').html('&copy; ' + year + ' <a href="https://www.southkingmedia.com">South King Media</a> | Powered by South King Media');
});
</script>
<script type="65e35b82932051ca2ab488f3-text/javascript">
jQuery(function($){
    $('.et_pb_widget.widget_search .search-field').attr('placeholder', 'SEARCH THE B-TOWN BLOG...').css('opacity','1'); 
});
</script>
<script type="65e35b82932051ca2ab488f3-text/javascript">
(function(d) {
  var el, fjs = d.getElementsByTagName('script')[0];
	el = d.createElement('script');
	el.id = "js-pp-banner";
	el.src = "//dashboard.presspatron.com/dev/banner?b=JwTFSrWmdN2iWLPzyeNAyDL5";
	fjs.parentNode.insertBefore(el, fjs);
}(document));
</script>
<div id="pp-banner"></div>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-6242924-1" type="65e35b82932051ca2ab488f3-text/javascript"></script>
<script type="65e35b82932051ca2ab488f3-text/javascript">
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-6242924-1');
</script>
<meta property="fb:pages" content="26665821728">
<script type="65e35b82932051ca2ab488f3-text/javascript">
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window, document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '731428661144435');
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=731428661144435&amp;ev=PageView&amp;noscript=1"></noscript>

<script type="65e35b82932051ca2ab488f3-text/javascript"> window._peq = window._peq || []; window._peq.push(["init"]); </script>
<script src="https://clientcdn.pushengage.com/core/49c8cebc-8ec8-4d2c-8119-b6008367.js" async type="65e35b82932051ca2ab488f3-text/javascript"></script><script src="https://ajax.cloudflare.com/cdn-cgi/scripts/7089c43e/cloudflare-static/rocket-loader.min.js" data-cf-settings="65e35b82932051ca2ab488f3-|49"></script><link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/et-cache/global/et-extra-customizer-global-161436335679.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /><script src="https://ajax.cloudflare.com/cdn-cgi/scripts/7089c43e/cloudflare-static/rocket-loader.min.js" data-cf-settings="65e35b82932051ca2ab488f3-|49"></script><link rel="stylesheet" id="et-core-unified-tb-144424-tb-144455-150257-cached-inline-styles" href="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/et-cache/150257/et-core-unified-tb-144424-tb-144455-150257-161480667434.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /><script type="65e35b82932051ca2ab488f3-text/javascript">var ezouid = "1";</script><base href="https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/"><script type="65e35b82932051ca2ab488f3-text/javascript">
var ezoTemplate = 'old_site_noads';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type="65e35b82932051ca2ab488f3-text/javascript">
var soc_app_id = '0';
var did = 145975;
var ezdomain = 'b-townblog.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"city":"","country":"US","days_since_last_visit":-1,"domain_id":145975,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":0,"page_ad_positions":"","page_view_count":0,"page_view_id":"4d6fbfcd-b203-4a79-5824-c3faca7fbb13","position_selection_id":0,"postal_code":"","pv_event_count":0,"response_size_orig":109114,"response_time_orig":7,"serverid":"3.218.208.133:945","state":"","t_epoch":1614808111,"template_id":120,"time_on_site_visit":0,"url":"https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/","user_id":0,"weather_precipitation":0,"weather_summary":"","weather_temperature":0,"word_count":1377,"worst_bad_word_level":4};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?dcb=192-0&cb=2&v=9" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_145975=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["4d6fbfcd-b203-4a79-5824-c3faca7fbb13", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script><script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body class="post-template-default single single-post postid-150257 single-format-standard et-tb-has-template et-tb-has-header et-tb-has-footer tribe-no-js et_extra et_fullwidth_nav et_fullwidth_secondary_nav et_fixed_nav et_pb_gutters4 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">

<noscript>
			<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-W3XBHN9" height="0" width="0" style="display:none;visibility:hidden"></iframe>
		</noscript>

<div id="page-container" class="page-container">
<div id="et-boc" class="et-boc">
<header class="et-l et-l--header">
<div class="et_builder_inner_content et_pb_gutters4">
<div class="et_pb_section et_pb_section_0_tb_header et_pb_with_background et_section_regular">
<div class="et_pb_row et_pb_row_0_tb_header et_pb_gutters2 et_pb_row--with-menu">
<div class="et_pb_column et_pb_column_1_2 et_pb_column_0_tb_header  et_pb_css_mix_blend_mode_passthrough et_pb_column--with-menu">
<div class="et_pb_module et_pb_code et_pb_code_0_tb_header">
<div class="et_pb_code_inner">

<div class="spt-container spt-border" style="border: solid 3px inherit;border-radius: 0px;width: 100%;"><div class="spt-label" style="float: left;margin: 0;padding: 0 10px;color: #ffffff;background-color: inherit;font-size: 100%;border-radius: 0px;">TRENDING</div><div class="spt-marquee" data-direction="left" data-duplicated="true" data-duration="200" data-gap="0" data-speed="20" data-pauseOnHover="true" data-delayBeforeStart="100" data-startVisible="true" data-loop="1" style="width:auto;margin: 0;padding: 0;font-size: 100%;background-color: inherit;overflow: hidden;"><span class="spt-item" style="padding: 0 10px;"><a class="spt-link" style="color: #ffffff;" target="_self" href="https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/">Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released</a></span><span class="spt-item" style="padding: 0 10px;"><a class="spt-link" style="color: #ffffff;" target="_self" href="https://b-townblog.com/2021/03/03/reminder-king-countys-virtual-town-hall-on-covid-vaccines-is-tonight/">REMINDER: King County&#8217;s Virtual Town Hall on COVID vaccines is tonight</a></span><span class="spt-item" style="padding: 0 10px;"><a class="spt-link" style="color: #ffffff;" target="_self" href="https://b-townblog.com/2021/03/02/two-former-burien-women-mayors-honored-by-city-council-for-womens-history-month/">Two former Burien women Mayors honored by City Council for Women’s History Month</a></span><span class="spt-item" style="padding: 0 10px;"><a class="spt-link" style="color: #ffffff;" target="_self" href="https://b-townblog.com/2021/03/02/memorial-bench-honoring-conlan-anderson-installed-at-puget-sound-park/">Memorial bench honoring Conlan Anderson installed at Puget Sound Park</a></span><span class="spt-item" style="padding: 0 10px;"><a class="spt-link" style="color: #ffffff;" target="_self" href="https://b-townblog.com/2021/03/01/kennedy-catholic-high-school-seeking-publics-help-identifying/">Kennedy Catholic High School seeking public&#8217;s help identifying vandals who damaged campus</a></span><span class="spt-item" style="padding: 0 10px;"><a class="spt-link" style="color: #ffffff;" target="_self" href="https://b-townblog.com/2021/03/01/eligibility-expanded-to-65-and-over-at-kent-and-auburn-community-vaccination-sites/">Eligibility expanded to 65 and over at Kent and Auburn vaccination sites</a></span></div></div></div>
</div> <div class="et_pb_module et_pb_menu et_pb_menu_0_tb_header et_pb_bg_layout_light  et_pb_text_align_left et_dropdown_animation_fade et_pb_menu--without-logo et_pb_menu--style-left_aligned">
<div class="et_pb_menu_inner_container clearfix">
<div class="et_pb_menu__wrap">
<div class="et_pb_menu__menu">
<nav class="et-menu-nav"><ul id="menu-secondary-1-7-20" class="et-menu nav"><li id="menu-item-144432" class="et_pb_menu_page_id-143239 menu-item menu-item-type-post_type menu-item-object-page menu-item-144432"><a href="https://b-townblog.com/subscribe-to-our-free-daily-newsletter/">FREE Newsletter</a></li>
<li id="menu-item-144429" class="et_pb_menu_page_id-136106 menu-item menu-item-type-post_type menu-item-object-page menu-item-144429"><a href="https://b-townblog.com/advertise/">Advertise</a></li>
<li id="menu-item-144433" class="et_pb_menu_page_id-135114 menu-item menu-item-type-post_type menu-item-object-page menu-item-144433"><a href="https://b-townblog.com/how-to-submit-to-the-blog/">How to submit</a></li>
<li id="menu-item-144430" class="et_pb_menu_page_id-43 menu-item menu-item-type-post_type menu-item-object-page menu-item-144430"><a href="https://b-townblog.com/about/">About</a></li>
<li id="menu-item-144431" class="et_pb_menu_page_id-78 menu-item menu-item-type-post_type menu-item-object-page menu-item-144431"><a href="https://b-townblog.com/contact/">Contact</a></li>
</ul></nav>
</div>
<div class="et_mobile_nav_menu">
<a href="#" class="mobile_nav closed">
<span class="mobile_menu_bar"></span>
</a>
</div>
</div>
</div>
</div>
</div> <div class="et_pb_column et_pb_column_1_2 et_pb_column_1_tb_header  et_pb_css_mix_blend_mode_passthrough et-last-child">
<div class="et_pb_module et_pb_code et_pb_code_1_tb_header">
<div class="et_pb_code_inner"><broadstreet-zone zone-id="72549"></broadstreet-zone></div>
</div> 
</div> 
</div> 
</div> <div class="et_pb_section et_pb_section_1_tb_header et_pb_with_background et_section_regular">
<div class="et_pb_row et_pb_row_1_tb_header">
<div class="et_pb_column et_pb_column_4_4 et_pb_column_2_tb_header  et_pb_css_mix_blend_mode_passthrough et-last-child">
<div class="et_pb_module et_pb_code et_pb_code_2_tb_header">
<div class="et_pb_code_inner"><div id="pp-banner"></div></div>
</div> 
</div> 
</div> <div class="et_pb_row et_pb_row_2_tb_header et_pb_gutters1 et_pb_row--with-menu">
<div class="et_pb_column et_pb_column_4_4 et_pb_column_3_tb_header  et_pb_css_mix_blend_mode_passthrough et-last-child et_pb_column--with-menu">
<div class="et_pb_module et_pb_menu et_pb_menu_1_tb_header et_pb_bg_layout_light  et_pb_text_align_left et_dropdown_animation_fade et_pb_menu--with-logo et_pb_menu--style-left_aligned">
<div class="et_pb_menu_inner_container clearfix">
<div class="et_pb_menu__logo-wrap">
<div class="et_pb_menu__logo">
<a href="https://b-townblog.com/"><img loading="lazy" src="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/uploads/2020/05/btown_logoSKM20d.png" alt="" height="auto" width="auto" class="wp-image-146891" /></a>
</div>
</div>
<div class="et_pb_menu__wrap">
<div class="et_pb_menu__menu">
<nav class="et-menu-nav"><ul id="menu-primary-1-7-20" class="et-menu nav"><li id="menu-item-146171" class="et_pb_menu_page_id-146171 menu-item menu-item-type-custom menu-item-object-custom menu-item-146171"><a href="https://b-townblog.com/category/covid-19/">COVID-19</a></li>
<li id="menu-item-144436" class="et_pb_menu_page_id-50 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-144436"><a href="https://b-townblog.com/category/crime/">Crime</a></li>
<li id="menu-item-144435" class="et_pb_menu_page_id-144435 menu-item menu-item-type-custom menu-item-object-custom menu-item-144435"><a href="https://b-townblog.com/events/">Events</a></li>
<li id="menu-item-144776" class="et_pb_menu_page_id-144776 menu-item menu-item-type-custom menu-item-object-custom menu-item-144776"><a href="https://b-townblog.com/jobs/">Jobs</a></li>
<li id="menu-item-144439" class="et_pb_menu_page_id-8 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144439"><a href="https://b-townblog.com/category/arts/">Arts</a></li>
<li id="menu-item-144441" class="et_pb_menu_page_id-37 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144441"><a href="https://b-townblog.com/category/business/">Business</a></li>
<li id="menu-item-144434" class="et_pb_menu_page_id-137556 menu-item menu-item-type-post_type menu-item-object-page menu-item-144434"><a href="https://b-townblog.com/coupons/">Coupons</a></li>
<li id="menu-item-144438" class="et_pb_menu_page_id-135305 menu-item menu-item-type-post_type menu-item-object-page menu-item-144438"><a href="https://b-townblog.com/weather/">Weather</a></li>
<li id="menu-item-144449" class="et_pb_menu_page_id-144449 menu-item menu-item-type-custom menu-item-object-custom menu-item-144449"><a target="_blank" rel="noopener" href="https://burien.bhhsnwrealestate.com"><img loading="lazy" src="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/BHHSLogoforMenu167x69.png" align="top" alt="Berkshire Hathaway HomeServices Northwest Realty" width="152" height="52"></a></li>
</ul></nav>
</div>
<div class="et_mobile_nav_menu">
<a href="#" class="mobile_nav closed">
<span class="mobile_menu_bar"></span>
</a>
</div>
</div>
</div>
</div>
</div> 
</div> 
</div>  </div>
</header>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<center><em>If you appreciate our award-winning local journalism, please…</em>
<div class="pp-donate-button"></div></center> <article id="post-150257" class="module single-post-module post-150257 post type-post status-publish format-standard has-post-thumbnail hentry category-burien category-burien-news-2 category-covid-19 category-crime category-featured-post category-news category-police tag-burien tag-burien-police-department tag-covid-19 tag-crime tag-king-county-sherffs-office tag-mail tag-mail-theft tag-news tag-postal-service tag-theft tag-three-tree-point tag-us-postal-service et-has-post-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released</h1>
<div class="post-meta vcard">
<p><span class="updated">Mar 3, 2021</span> | <a href="https://b-townblog.com/category/burien/" rel="tag">Burien</a>, <a href="https://b-townblog.com/category/burien-news-2/" rel="tag">Burien News</a>, <a href="https://b-townblog.com/category/covid-19/" rel="tag">COVID-19</a>, <a href="https://b-townblog.com/category/crime/" rel="tag">Crime</a>, <a href="https://b-townblog.com/category/featured-post/" rel="tag">Featured Post</a>, <a href="https://b-townblog.com/category/news/" rel="tag">News</a>, <a href="https://b-townblog.com/category/police/" rel="tag">Police</a></p>
</div>
</div>
<div class="post-thumbnail header">
<img src="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/uploads/2020/12/BTB-BurienPoliceLogo2020-1280x640.jpg" alt="Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released" /> </div>
<div class="post-wrap">
<div class="post-content entry-content">
<table id="trinity-audio-table" style="width:100%; display: table;">
<tr>
<td id="trinity-audio-tab" style="border: none;">
<div id="trinity-audio-player-label"></div>
<script type="65e35b82932051ca2ab488f3-text/javascript">var TRINITY_TTS_WP_CONFIG = {"cleanText":"Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released. Burien Police \/ King County Sheriff's Office are reporting that they detained three people involved in a recent mail theft in the 16500 block of Maplewild Ave SW in Three Tree Point (map below).\r\n\r\nPolice say that on Saturday morning, Feb. 27, 2021 at 5:17 a.m., deputies responded to a 911 call from a resident who heard a commotion near their home.\r\n\r\nMultiple officers responded, and deputies located and detained three people suspected of taking mail out of people\u2019s mailboxes.\r\n\r\nThe suspects were all positively identified and several pieces of stolen mail were recovered.\r\n\r\nOne of the suspects however had an outstanding warrant and was going to be booked into King County Jail on her warrant. During her interview, she told police that she had tested positive for COVID on Feb. 26. The sergeant was notified and screened the booking. Based on the alleged COVID test information and the fact this was a property crime warrant, the decision was made to not book her into jail. She was released.\r\n\r\nSome of the stolen mail items were returned to homeowners, evidence was submitted for processing and officers completed a thorough case report. This case was forwarded to detectives, who will review the case to see if it meets the threshold for referral to the US Postal Inspectors or if it will be filed locally.\r\n\r\nHere's what one neighbor said about this incident:\r\n\"A neighbor said that someone happened to be outside taking pictures of the moon when they saw the three suspects along the road and called the police. The three then moved south as a patrol car with searchlights arrived. One of the female suspects hid behind a truck she was prowling while the other two ducked onto a parking platform behind a car and\/or stairs. An officer spotted the female by the truck, who prior to getting busted threw the stolen mail over the railing into the bushes. The owner of the house where the other two were hiding heard the commotion and spotted the other two on his cameras and called 911. Four other patrol cars showed up and after a short search found the other two.\r\n\"Finally, a win for the good guys \u2013 NOT.\"\r\nThe King County Sheriff\u2019s Office told The B-Town Blog that it investigates all thefts based on the evidence and other factors.\r\n\r\n\"It would be determined by the assigned detective if the resources of the US Postal Inspector were appropriate in a given case,\" Sgt. Tim Meyer told The B-Town Blog. \"Unlike KCSO, Postal Inspectors do not have 24\/7 resources who can arrest\/book subjects.\u00a0Whatever the theft (mail, shoplifting, etc.), a deputy must be able to establish a burden of proof.\"\r\n\r\n\"I know sometimes people associate not being immediately booked with the lack of police action, but that is not accurate,\" Police Chief Ted Boe said in a statement. \"We have been in a pandemic for over a year and have had to manage jail populations at both SCORE and the King County Jail to limit the risk of an outbreak in the facilities. As such, we have been asked by King County to prioritize felony bookings, with the direction that bookings should be limited to cases 'that pose the most immediate risk to public safety.' In light of that guidance, we evaluate the level of crime, ability to identify the suspects for future prosecution and the danger to the public in making our booking decisions. In this case, it would be difficult to justify the booking based on these criteria, particularly based on the potential for introducing COVID into the custody environment.\"\r\n\r\n\"Mail theft has been an issue as of late and I am pleased that police have identified these suspects,\" Burien City Manager Brian Wilson said.\r\n\r\n\r\n\u00a0\r\n","pluginVersion":"3.0.4"};</script><div class="trinityAudioPlaceholder"></div>
</td>
</tr>
</table><script type="65e35b82932051ca2ab488f3-text/javascript">console.debug('TRINITY_WP', 'trinity_content_filter');</script><p><strong>Burien Police / King County Sheriff&#8217;s Office are reporting that they detained three people involved in a recent mail theft in the 16500 block of Maplewild Ave SW in Three Tree Point (map below).</strong></p>
<p>Police say that on Saturday morning, Feb. 27, 2021 at 5:17 a.m., deputies responded to a 911 call from a resident who heard a commotion near their home.</p>
<p>Multiple officers responded, and deputies located and detained three people suspected of taking mail out of people’s mailboxes.</p>
<p>The suspects were all positively identified and several pieces of stolen mail were recovered.</p>
<p>One of the suspects however had an outstanding warrant and was going to be booked into King County Jail on her warrant. During her interview, she told police that she had tested positive for COVID on Feb. 26. The sergeant was notified and screened the booking. Based on the alleged COVID test information and the fact this was a property crime warrant, the decision was made to not book her into jail. She was released.</p>
<p>Some of the stolen mail items were returned to homeowners, evidence was submitted for processing and officers completed a thorough case report. This case was forwarded to detectives, who will review the case to see if it meets the threshold for referral to the US Postal Inspectors or if it will be filed locally.</p>
<p>Here&#8217;s what one neighbor said about this incident:</p>
<p style="padding-left: 40px;">&#8220;A neighbor said that someone happened to be outside taking pictures of the moon when they saw the three suspects along the road and called the police. The three then moved south as a patrol car with searchlights arrived. One of the female suspects hid behind a truck she was prowling while the other two ducked onto a parking platform behind a car and/or stairs. An officer spotted the female by the truck, who prior to getting busted threw the stolen mail over the railing into the bushes. The owner of the house where the other two were hiding heard the commotion and spotted the other two on his cameras and called 911. Four other patrol cars showed up and after a short search found the other two.</p>
<p style="padding-left: 40px;">&#8220;Finally, a win for the good guys – NOT.&#8221;</p>
<p>The King County Sheriff’s Office told The B-Town Blog that it investigates all thefts based on the evidence and other factors.</p>
<p>&#8220;It would be determined by the assigned detective if the resources of the US Postal Inspector were appropriate in a given case,&#8221; Sgt. Tim Meyer told The B-Town Blog. &#8220;Unlike KCSO, Postal Inspectors do not have 24/7 resources who can arrest/book subjects. Whatever the theft (mail, shoplifting, etc.), a deputy must be able to establish a burden of proof.&#8221;</p>
<p>&#8220;I know sometimes people associate not being immediately booked with the lack of police action, but that is not accurate,&#8221; Police Chief Ted Boe said in a statement. &#8220;We have been in a pandemic for over a year and have had to manage jail populations at both SCORE and the King County Jail to limit the risk of an outbreak in the facilities. As such, we have been asked by King County to prioritize felony bookings, with the direction that bookings should be limited to cases &#8216;that pose the most immediate risk to public safety.&#8217; In light of that guidance, we evaluate the level of crime, ability to identify the suspects for future prosecution and the danger to the public in making our booking decisions. In this case, it would be difficult to justify the booking based on these criteria, particularly based on the potential for introducing COVID into the custody environment.&#8221;</p>
<p>&#8220;Mail theft has been an issue as of late and I am pleased that police have identified these suspects,&#8221; Burien City Manager Brian Wilson said.</p>
<p><center><iframe src="https://www.google.com/maps/embed?pb=!1m18!1m12!1m3!1d2859.3817888507847!2d-122.3736797486973!3d47.45493337907262!2m3!1f0!2f0!3f0!3m2!1i1024!2i768!4f13.1!3m3!1m2!1s0x549044ef22bdf5dd%3A0xd0adcfc108c252a1!2s16500%20Maplewild%20Ave%20SW%2C%20Burien%2C%20WA%2098166!5e1!3m2!1sen!2sus!4v1614806288789!5m2!1sen!2sus" width="600" height="450" style="border:0;" allowfullscreen="" loading="lazy"></iframe></center><br />
&nbsp;</p>
<div style='margin:5px auto; margin-bottom: 15px;' id='zone_load_1003078987'><broadstreet-zone callback="zone_load_1003078987" zone-id="72541" keywords="not_home_page,not_landing_page,is_article_page,burien,burien-news-2,covid-19,crime,featured-post,news,police,burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><script type="65e35b82932051ca2ab488f3-text/javascript">window.zone_load_1003078987 = function(z, d) { if (!d.count) document.getElementById('zone_load_1003078987').style.display = 'none'; };</script> </div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
<a href="https://www.facebook.com/sharer.php?u=https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/&#038;t=Burien%20Police%20detain%20postal%20thieves%2C%20recover%20stolen%20mail%3B%20alleged%20COVID%20positive%20suspect%20released" class="social-share-link" title="Share &quot;Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released&quot; via Facebook" data-network-name="facebook" data-share-title="Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released" data-share-url="https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/">
<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span>
</a><a href="https://twitter.com/intent/tweet?text=Burien%20Police%20detain%20postal%20thieves%2C%20recover%20stolen%20mail%3B%20alleged%20COVID%20positive%20suspect%20released%20https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/" class="social-share-link" title="Share &quot;Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released&quot; via Twitter" data-network-name="twitter" data-share-title="Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released" data-share-url="https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/">
<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released&quot; via Email" data-network-name="basic_email" data-share-title="Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released" data-share-url="https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/">
<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &quot;Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released&quot; via Print" data-network-name="basic_print" data-share-title="Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released" data-share-url="https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/">
<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span>
</a> </div>
<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #669933;
									}
								</style>
</div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="https://b-townblog.com/2021/03/03/reminder-king-countys-virtual-town-hall-on-covid-vaccines-is-tonight/" rel="prev"><span class="button">Previous</span><span class="title">REMINDER: King County&#8217;s Virtual Town Hall on COVID vaccines is tonight</span></a> </div>
<div class="nav-link nav-link-next">
</div>
</div>
</nav>
<center><div class="pp-donate-button"></div></center>
 

<link href="//cdn-images.mailchimp.com/embedcode/slim-10_7.css" rel="stylesheet" type="text/css"><style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif;  width:500px;}
	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style><div id="mc_embed_signup">
<form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=af702f1850" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Subscribe to our FREE Daily Digest Email!</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_af702f1850" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</div>
</form>
</div>

</div>
<div class="et_pb_extra_column_sidebar">
<div id="search-3" class="et_pb_widget widget_search"><h4 class="widgettitle">Search The B-Town (Burien) Blog</h4><form role="search" method="get" class="search-form" action="https://b-townblog.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div> <div id="bs_zones-2" class="et_pb_widget bs_zones"><h4 class="widgettitle">Support Our Sponsors</h4><div><broadstreet-zone zone-id="72555" keywords="not_home_page,not_landing_page,is_article_page,burien,burien-news-2,covid-19,crime,featured-post,news,police,burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released,post" soft-keywords="true" zone-alias="rotatingtopright"></broadstreet-zone></div></div> <div id="bs_zones-22" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76533" keywords="not_home_page,not_landing_page,is_article_page,burien,burien-news-2,covid-19,crime,featured-post,news,police,burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-24" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="72575" keywords="not_home_page,not_landing_page,is_article_page,burien,burien-news-2,covid-19,crime,featured-post,news,police,burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released,post" soft-keywords="true" zone-alias="prime#2"></broadstreet-zone></div></div> <div id="bs_zones-21" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="72685" keywords="not_home_page,not_landing_page,is_article_page,burien,burien-news-2,covid-19,crime,featured-post,news,police,burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released,post" soft-keywords="true" zone-alias="prime3"></broadstreet-zone></div></div> <div id="text-18" class="et_pb_widget widget_text"><h4 class="widgettitle">2021 CANDIDATE&#8217;S GUIDE</h4> <div class="textwidget"><p><a href="https://b-townblog.com/2021/02/17/think-youd-be-a-better-burien-city-councilmember-heres-how-you-can-run-for-office/"><img loading="lazy" class="aligncenter size-full wp-image-145675" src="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/uploads/2021/02/BTB-CandidatesGuide2021.jpg" alt="" width="300" height="100" /></a></p>
</div>
</div> <div id="text-14" class="et_pb_widget widget_text"><h4 class="widgettitle">SUPPORT LOCAL RESTAURANTS</h4> <div class="textwidget"><p><a href="https://b-townblog.com/2020/03/17/support-our-local-restaurants-during-the-quarantine-heres-how-where-to-order-food/"><img loading="lazy" class="aligncenter size-full wp-image-145722" src="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/uploads/2020/03/SupportLocalRestaurants300x150WidgetArt.jpg" alt="" width="300" height="150" /></a></p>
</div>
</div> <div id="text-16" class="et_pb_widget widget_text"><h4 class="widgettitle">SUPPORT BLACK-OWNED BUSINESSES</h4> <div class="textwidget"><p><a href="https://b-townblog.com/2020/06/05/heres-how-you-can-support-local-black-owned-businesses/"><img loading="lazy" class="aligncenter size-full wp-image-147112" src="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/uploads/2020/06/SupportBlackBusinesses300x150WidgetArt.jpg" alt="" width="300" height="150" /></a></p>
</div>
</div> <div id="bs_zones-9" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="72704" keywords="not_home_page,not_landing_page,is_article_page,burien,burien-news-2,covid-19,crime,featured-post,news,police,burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released,post" soft-keywords="true" zone-alias="Steadman"></broadstreet-zone></div></div> <div id="search-4" class="et_pb_widget widget_search"><h4 class="widgettitle">Search The B-Town Blog</h4><form role="search" method="get" class="search-form" action="https://b-townblog.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div> <div id="media_image-2" class="et_pb_widget widget_media_image"><h4 class="widgettitle">SUPPORT LOCAL JOURNALISM</h4><a href="https://b-townblog.com/support-local-journalism/"><img width="300" height="250" src="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/uploads/2020/05/BTBSupportAd300x250-2SPJ.jpg" class="image wp-image-146836  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" title="SUPPORT LOCAL JOURNALISM" /></a></div> <div id="weather_atlas-3" class="et_pb_widget widget_weather_atlas"><h4 class="widgettitle">WEATHER</h4><div class='weather-atlas-wrapper' style='background:#669933;border:1px solid #558822;color:#fff;'><div class='weather-atlas-header' style='border-bottom:1px solid #558822'><div class='weather-atlas-header-title-wrapper'><div class='weather-atlas-header-title'>Burien</div><div class='city_selector_toggle_div autocomplete' style='display:none;'><script type="65e35b82932051ca2ab488f3-text/javascript">/*<![CDATA[*/var weather_atlas_language = 'en';/*]]>*/</script><input class='city_name' id='city_name' name='city_name' type='text' value='' placeholder='type and select location from drop-down'></div></div><div class='city_selector_toggle'><a href='#' class='city_selector_toggle_link' style='color:#fff' title='Location'>&#9673;</a></div></div><div class='weather-atlas-body'><div class='current_temp'><i class='wi wi-fw wi-weather-34'></i><span class='temp'>48°</span><div class='current_text'>Fair</div><div class='sunrise_sunset'>6:44am<i class='wi wi-fw wi-weather-32'></i>5:57pm PST</div></div><span class='current_text_2'>Feels like: 48<small>°F</small><br />Wind: 0<small>mph</small> SSW<br />Humidity: 68<small>%</small><br />Pressure: 29.85<small>"Hg</small><br />UV index: 2</span><div class='hourly hours' style='border-bottom:1px solid #558822'><span class='extended_hour extended_hour_1'>14<small>h</small></span><span class='extended_hour extended_hour_2'>15<small>h</small></span></div><div class='hourly'><span class='extended_hour extended_hour_1' title='Mostly Sunny'>54<small>°F</small><br /><i class='wi wi-fw wi-weather-34'></i></span><span class='extended_hour extended_hour_2' title='Mostly Sunny'>54<small>°F</small><br /><i class='wi wi-fw wi-weather-34'></i></span></div><div class='daily days' style='border-bottom:1px solid #558822'><span class='extended_day extended_day_1'>Thu</span><span class='extended_day extended_day_2'>Fri</span><span class='extended_day extended_day_3'>Sat</span><span class='extended_day extended_day_4'>Sun</span></div><div class='daily'><span class='extended_day extended_day_1' title='PM Light Rain'>57/45<small>°F</small><br /><i class='wi wi-fw wi-weather-11'></i></span><span class='extended_day extended_day_2' title='Light Rain'>50/41<small>°F</small><br /><i class='wi wi-fw wi-weather-11'></i></span><span class='extended_day extended_day_3' title='AM Showers'>52/39<small>°F</small><br /><i class='wi wi-fw wi-weather-39'></i></span><span class='extended_day extended_day_4' title='Showers'>50/36<small>°F</small><br /><i class='wi wi-fw wi-weather-11'></i></span></div></div><div class='weather-atlas-footer' style='border-top:1px solid #558822'><a href='https://www.weather-us.com/en/washington-usa/burien' title='Weather Atlas - Weather forecast Burien, Washington' style='color:#fff;' target='_blank'>Weather forecast <span class='weather-atlas-footer-block'>Burien, Washington &#9656;</span></a></div></div></div> <div id="text-4" class="et_pb_widget widget_text"><h4 class="widgettitle">WEATHER SPONSORED BY</h4> <div class="textwidget"><p><a href="https://www.seahurstsmiles.com" target="_blank" rel="noopener"><br />
<img loading="lazy" src="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/uploads/2019/10/WeatherSponsorSeahurstSmiles300b.jpg" alt="seahurstsmiles" width="300" height="93" border="0" /></a></p>
</div>
</div> <div id="bs_zones-11" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="72559" keywords="not_home_page,not_landing_page,is_article_page,burien,burien-news-2,covid-19,crime,featured-post,news,police,burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released,post" soft-keywords="true" zone-alias="rightsidebar"></broadstreet-zone></div></div> <div id="bs_zones-25" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76016" keywords="not_home_page,not_landing_page,is_article_page,burien,burien-news-2,covid-19,crime,featured-post,news,police,burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-20" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="77427" keywords="not_home_page,not_landing_page,is_article_page,burien,burien-news-2,covid-19,crime,featured-post,news,police,burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="tribe-events-list-widget-2" class="et_pb_widget tribe-events-list-widget"><h4 class="widgettitle">Upcoming Events</h4>
<ol class="tribe-list-widget">
<li class="tribe-events-list-widget-events type-tribe_events post-150283 tribe-clearfix tribe-events-venue-146742 tribe-events-organizer-150284">

<h4 class="tribe-event-title">
<a href="https://b-townblog.com/event/150283/" rel="bookmark">King County&#8217;s Virtual Town Hall on COVID vaccines is Wed. night</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">March 3 @ 6:00 pm</span> - <span class="tribe-event-time">7:30 pm</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-150128 tribe-clearfix tribe-events-venue-142741">

<h4 class="tribe-event-title">
<a href="https://b-townblog.com/event/highline-heritage-museum-will-be-reopening-on-friday-mar-5/" rel="bookmark">Highline Heritage Museum will be reopening on Friday, Mar. 5</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">March 5 @ 1:00 pm</span> - <span class="tribe-event-time">5:00 pm</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-150234 tribe-clearfix tribe-events-venue-142741">

<h4 class="tribe-event-title">
<a href="https://b-townblog.com/event/ribbon-cutting-grand-reopening-of-highline-heritage-museum-will-be-friday-mar-5/" rel="bookmark">Ribbon Cutting &#038; Grand Reopening of Highline Heritage Museum will be Friday, Mar. 5</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">March 5 @ 1:00 pm</span> - <span class="tribe-event-time">2:00 pm</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-150189 tribe-clearfix tribe-events-venue-147632 tribe-events-organizer-137427">

<h4 class="tribe-event-title">
<a href="https://b-townblog.com/event/see-the-premiere-of-the-paper-tigers-film-at-discover-buriens-drive-in-theater-mar-6/" rel="bookmark">See the premiere of &#8216;The Paper Tigers&#8217; film at Discover Burien&#8217;s Drive-In Theater Mar. 6</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">March 6 @ 7:00 pm</span> - <span class="tribe-event-time">9:30 pm</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-149695 tribe-clearfix tribe-events-venue-146742 tribe-events-organizer-149608">

<h4 class="tribe-event-title">
<a href="https://b-townblog.com/event/environmental-science-centers-heroes-for-nature-gala-will-be-saturday-mar-13/" rel="bookmark">Environmental Science Center&#8217;s Heroes for Nature Gala will be Saturday, Mar. 13</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">March 13 @ 7:00 pm</span> - <span class="tribe-event-time">8:00 pm</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-150179 tribe-clearfix tribe-events-venue-146742 tribe-events-organizer-147419">

<h4 class="tribe-event-title">
<a href="https://b-townblog.com/event/rotary-clubs-virtual-poverty-bay-wine-festival-will-be-saturday-mar-27/" rel="bookmark">Rotary Club&#8217;s Virtual Poverty Bay Wine Festival will be Saturday, Mar. 27</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">March 27 @ 4:00 pm</span> - <span class="tribe-event-time">8:00 pm</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-149649 tribe-clearfix tribe-events-organizer-137427">

<h4 class="tribe-event-title">
<a href="https://b-townblog.com/event/dog-biscuit-crawl-for-burien-cares-will-be-saturday-april-17/" rel="bookmark">&#8216;Dog Biscuit Crawl&#8217; for Burien CARES will be Saturday, April 17</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">April 17</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-149634 tribe-clearfix tribe-events-venue-136291 tribe-events-organizer-137427">

<h4 class="tribe-event-title">
<a href="https://b-townblog.com/event/discover-buriens-clean-sweep-will-be-saturday-april-24/" rel="bookmark">Discover Burien&#8217;s &#8216;Clean Sweep&#8217; will be Saturday, April 24</a>
</h4>

<div class="tribe-event-duration">
 <span class="tribe-event-date-start">April 24 @ 8:00 am</span> - <span class="tribe-event-time">12:00 pm</span> </div>
</li>
</ol>
<p class="tribe-events-widget-link">
<a href="https://b-townblog.com/events/" rel="bookmark">View All Events</a>
</p>
</div> <script type="application/ld+json">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</script><div id="bs_zones-12" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76001" keywords="not_home_page,not_landing_page,is_article_page,burien,burien-news-2,covid-19,crime,featured-post,news,police,burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-16" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76116" keywords="not_home_page,not_landing_page,is_article_page,burien,burien-news-2,covid-19,crime,featured-post,news,police,burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="bs_zones-26" class="et_pb_widget bs_zones"><div><broadstreet-zone zone-id="76531" keywords="not_home_page,not_landing_page,is_article_page,burien,burien-news-2,covid-19,crime,featured-post,news,police,burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="text-7" class="et_pb_widget widget_text"><h4 class="widgettitle">Story Idea or News Tip?</h4> <div class="textwidget"><p><strong>Send story ideas &amp; tips to us at:</strong></p>
<p><center><a href="/cdn-cgi/l/email-protection#791c1d100d160b391b540d160e171b15161e571a1614"><strong><span class="__cf_email__" data-cfemail="9df8f9f4e9f2efddffb0e9f2eaf3fff1f2fab3fef2f0">[email&#160;protected]</span></strong></a></center><br />
<br />
You can also text us or leave a voicemail 24/7:<br />
<br />
<center><strong>(206) 659-1282</strong></center><br />
<br />
Or call our office at <strong>(206) 248-2565</strong>!</p>
</div>
</div> <div id="bs_zones-7" class="et_pb_widget bs_zones"><h4 class="widgettitle">Berkshire Hathaway HomeServices NW Realty</h4><div><broadstreet-zone zone-id="72544" keywords="not_home_page,not_landing_page,is_article_page,burien,burien-news-2,covid-19,crime,featured-post,news,police,burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div></div> <div id="zoom-social-icons-widget-2" class="et_pb_widget zoom-social-icons-widget"><h4 class="widgettitle">Follow us</h4>
<ul class="zoom-social-icons-list zoom-social-icons-list--with-canvas zoom-social-icons-list--rounded zoom-social-icons-list--align-center">
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://facebook.com/btownblog" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-facebook" data-hover-rule="background-color" data-hover-color="#3b5998" style="background-color : #3b5998; font-size: 24px; padding:3px"></span>
<span class="zoom-social_icons-list__label">Facebook</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://twitter.com/btownblog" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-twitter" data-hover-rule="background-color" data-hover-color="#55acee" style="background-color : #55acee; font-size: 24px; padding:3px"></span>
<span class="zoom-social_icons-list__label">Twitter</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://instagram.com/btownblog" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-instagram" data-hover-rule="background-color" data-hover-color="#e4405f" style="background-color : #e4405f; font-size: 24px; padding:3px"></span>
<span class="zoom-social_icons-list__label">Instagram</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://www.youtube.com/channel/UCC7UufGSGL-p087Eya-Z1cw" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-youtube" data-hover-rule="background-color" data-hover-color="#e02a20" style="background-color : #e02a20; font-size: 24px; padding:3px"></span>
<span class="zoom-social_icons-list__label">YouTube</span>
</a>
</li>
<li class="zoom-social_icons-list__item">
<a class="zoom-social_icons-list__link" href="https://flipboard.com/@southkingmedia/the-b-town-burien-blog-mr0otot4y" target="_blank">
<span class="zoom-social_icons-list-span social-icon socicon socicon-flipboard" data-hover-rule="background-color" data-hover-color="#E12828" style="background-color : #E12828; font-size: 24px; padding:3px"></span>
<span class="zoom-social_icons-list__label">Flipboard</span>
</a>
</li>
</ul>
</div> <div id="text-9" class="et_pb_widget widget_text"><h4 class="widgettitle">Subscribe to our Newsletter</h4> <div class="textwidget"><p>
<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=af702f1850" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Subscribe to our FREE 6pm Daily Digest Newsletter</label><br />
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required><br />
</p>
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_af702f1850" tabindex="-1" value=""></div>
<div class="black"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</p></div>
</form>
</div>
<p></p>
</div>
</div> 
<div id="recent-posts-2" class="et_pb_widget widget_recent_entries">
<h4 class="widgettitle">Recent Posts</h4>
<ul>
<li>
<a href="https://b-townblog.com/2021/03/03/burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released/" aria-current="page">Burien Police detain postal thieves, recover stolen mail; alleged COVID positive suspect released</a>
</li>
<li>
<a href="https://b-townblog.com/2021/03/03/reminder-king-countys-virtual-town-hall-on-covid-vaccines-is-tonight/">REMINDER: King County&#8217;s Virtual Town Hall on COVID vaccines is tonight</a>
</li>
<li>
<a href="https://b-townblog.com/2021/03/02/two-former-burien-women-mayors-honored-by-city-council-for-womens-history-month/">Two former Burien women Mayors honored by City Council for Women’s History Month</a>
</li>
<li>
<a href="https://b-townblog.com/2021/03/02/memorial-bench-honoring-conlan-anderson-installed-at-puget-sound-park/">Memorial bench honoring Conlan Anderson installed at Puget Sound Park</a>
</li>
<li>
<a href="https://b-townblog.com/2021/03/01/kennedy-catholic-high-school-seeking-publics-help-identifying/">Kennedy Catholic High School seeking public&#8217;s help identifying vandals who damaged campus</a>
</li>
<li>
<a href="https://b-townblog.com/2021/03/01/eligibility-expanded-to-65-and-over-at-kent-and-auburn-community-vaccination-sites/">Eligibility expanded to 65 and over at Kent and Auburn vaccination sites</a>
</li>
<li>
<a href="https://b-townblog.com/2021/03/01/burien-arts-association-honors-artist-and-volunteer-of-the-year/">Burien Arts Association honors Artist and Volunteer of the Year</a>
</li>
</ul>
</div> 
<div id="wpp-2" class="et_pb_widget popular-posts">
<h4 class="widgettitle">Popular Posts</h4>

<ul class="wpp-list">
<li>
<a href="https://b-townblog.com/2020/02/15/two-teachers-forced-out-of-buriens-kennedy-catholic-high-school-due-to-lgbtq-status/" class="wpp-post-title" target="_self">Two teachers forced out of Burien&#8217;s Kennedy Catholic High School due to LGBT status</a>
<span class="wpp-meta post-stats"><span class="wpp-views">72.9k views</span></span>
</li>
<li>
<a href="https://b-townblog.com/2019/09/25/137281/" class="wpp-post-title" target="_self">Staff at Burien&#8217;s Countryside Cafe mourning recent loss of owner, friend</a>
<span class="wpp-meta post-stats"><span class="wpp-views">21.2k views</span></span>
</li>
<li>
<a href="https://b-townblog.com/2020/03/02/breaking-man-being-treated-for-coronavirus/" class="wpp-post-title" target="_self">BREAKING: Man being treated for coronavirus at Highline Medical Center</a>
<span class="wpp-meta post-stats"><span class="wpp-views">20.6k views</span></span>
</li>
<li>
<a href="https://b-townblog.com/2020/03/09/burien-declares-state-of-emergency-for-covid-19/" class="wpp-post-title" target="_self">City of Burien declares &#8216;State of Emergency&#8217; due to COVID-19 coronavirus</a>
<span class="wpp-meta post-stats"><span class="wpp-views">12.4k views</span></span>
</li>
<li>
<a href="https://b-townblog.com/2017/04/25/crime-increasing-in-burien-along-with-everywhere-in-s-king-county-chief-says/" class="wpp-post-title" target="_self">Crime increasing in Burien, along with everywhere in S. King County, Chief says</a>
<span class="wpp-meta post-stats"><span class="wpp-views">11k views</span></span>
</li>
<li>
<a href="https://b-townblog.com/2020/01/03/144381/" class="wpp-post-title" target="_self">Man waiting for tow truck found slumped over wheel in Burien Friday afternoon</a>
<span class="wpp-meta post-stats"><span class="wpp-views">10.2k views</span></span>
</li>
<li>
<a href="https://b-townblog.com/2020/03/16/coronavirus-testing-tents-are-being-set-up-at-cvs-pharmacy-in-burien/" class="wpp-post-title" target="_self">UPDATE: Coronavirus testing tents removed from CVS Pharmacy in Burien</a>
<span class="wpp-meta post-stats"><span class="wpp-views">9.7k views</span></span>
</li>
<li>
<a href="https://b-townblog.com/2020/03/17/support-our-local-restaurants-during-the-quarantine-heres-how-where-to-order-food/" class="wpp-post-title" target="_self">Support our local restaurants during the quarantine – here&#8217;s how/where to order food</a>
<span class="wpp-meta post-stats"><span class="wpp-views">9.6k views</span></span>
</li>
<li>
<a href="https://b-townblog.com/2020/01/06/b-town-biz-bargain-hunters-bummed-as-buriens-big-lots-has-closed/" class="wpp-post-title" target="_self">B-TOWN BIZ: Bargain hunters bummed as Burien&#8217;s Big Lots has closed</a>
<span class="wpp-meta post-stats"><span class="wpp-views">9.2k views</span></span>
</li>
<li>
<a href="https://b-townblog.com/2020/12/11/infected-employee-from-burien-fred-meyer-concerned-about-recent-covid-outbreak-at-store/" class="wpp-post-title" target="_self">Infected employee at Burien Fred Meyer concerned about recent COVID outbreak at store</a>
<span class="wpp-meta post-stats"><span class="wpp-views">8.8k views</span></span>
</li>
</ul>
</div> 
<div id="text-13" class="et_pb_widget widget_text"><h4 class="widgettitle">COPING DURING THE QUARANTINE</h4> <div class="textwidget"><p><a href="https://b-townblog.com/cabin-fever-chronicles/"><img loading="lazy" class="aligncenter size-full wp-image-145675" src="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/uploads/2020/05/CabinFeverChronicles300x150-2b.jpg" alt="" width="300" height="100" /></a></p>
</div>
</div> <div id="bs_zones-4" class="et_pb_widget bs_zones"><h4 class="widgettitle">Help Local Non-Profits</h4><div><broadstreet-zone zone-id="72580" keywords="not_home_page,not_landing_page,is_article_page,burien,burien-news-2,covid-19,crime,featured-post,news,police,burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released,post" soft-keywords="true" zone-alias="nonprofit sidebar"></broadstreet-zone></div></div> </div>
</div> 
</div> 
</div> 
<footer class="et-l et-l--footer">
<div class="et_builder_inner_content et_pb_gutters4"><div class="et_pb_with_border et_pb_section et_pb_section_0_tb_footer et_pb_with_background et_section_regular">
<div class="et_pb_row et_pb_row_0_tb_footer">
<div class="et_pb_column et_pb_column_1_4 et_pb_column_0_tb_footer  et_pb_css_mix_blend_mode_passthrough">
<div class="et_pb_module et_pb_image et_pb_image_0_tb_footer">
<span class="et_pb_image_wrap "><img loading="lazy" src="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/uploads/2020/05/btown_logoSKM20d.png" alt="" title="btown_logoSKM20d" height="auto" width="auto" class="wp-image-146891" /></span>
</div><div class="et_pb_module et_pb_text et_pb_text_0_tb_footer  et_pb_text_align_left et_pb_bg_layout_dark">
<div class="et_pb_text_inner"><p>The B-Town Blog is Burien&#8217;s multiple award-winning hyperlocal news/events website dedicated to independent journalism.</p></div>
</div> <ul class="et_pb_module et_pb_social_media_follow et_pb_social_media_follow_0_tb_footer clearfix  et_pb_text_align_left et_pb_bg_layout_light">
<li class='et_pb_social_media_follow_network_0_tb_footer et_pb_social_icon et_pb_social_network_link  et-social-facebook et_pb_social_media_follow_network_0_tb_footer'><a href='https://www.facebook.com/btownblog/' class='icon et_pb_with_border' title='Follow on Facebook' target="_blank"><span class='et_pb_social_media_follow_network_name' aria-hidden='true'>Follow</span></a></li><li class='et_pb_social_media_follow_network_1_tb_footer et_pb_social_icon et_pb_social_network_link  et-social-twitter et_pb_social_media_follow_network_1_tb_footer'><a href='https://twitter.com/btownblog' class='icon et_pb_with_border' title='Follow on Twitter' target="_blank"><span class='et_pb_social_media_follow_network_name' aria-hidden='true'>Follow</span></a></li><li class='et_pb_social_media_follow_network_2_tb_footer et_pb_social_icon et_pb_social_network_link  et-social-instagram et_pb_social_media_follow_network_2_tb_footer'><a href='https://instagram.com/btownblog' class='icon et_pb_with_border' title='Follow on Instagram' target="_blank"><span class='et_pb_social_media_follow_network_name' aria-hidden='true'>Follow</span></a></li>
</ul> 
</div> <div class="et_pb_column et_pb_column_1_4 et_pb_column_1_tb_footer  et_pb_css_mix_blend_mode_passthrough">
<div class="et_pb_module et_pb_text et_pb_text_1_tb_footer et_clickable  et_pb_text_align_left et_pb_bg_layout_dark">
<div class="et_pb_text_inner"><h4>Quick Links</h4>
<ul>
<li><a href="https://b-townblog.com/advertise/">Advertise</a></li>
<li><a href="https://b-townblog.com/how-to-submit-to-the-blog/">How to Submit</a></li>
<li><a href="https://b-townblog.com/privacy-policy-terms-of-service/">Privacy Policy</li>
<p></a></p>
<li>
<li><a href="https://b-townblog.com/about/">About Us</a></li>
<li><a href="https://b-townblog.com/contact/">Contact Us</a></li>
</ul></div>
</div> 
</div> <div class="et_pb_column et_pb_column_1_2 et_pb_column_2_tb_footer  et_pb_css_mix_blend_mode_passthrough et-last-child">
<div class="et_pb_module et_pb_code et_pb_code_0_tb_footer">
<div class="et_pb_code_inner">
<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&#038;id=af702f1850" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Get Burien News delivered via email – subscribe to our FREE Daily Digest</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>

<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_af702f1850" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
 </div>
</form>
</div>
</div>
</div> 
</div> 
</div> <div class="et_pb_row et_pb_row_1_tb_footer">
<div class="et_pb_column et_pb_column_4_4 et_pb_column_3_tb_footer  et_pb_css_mix_blend_mode_passthrough et-last-child">
<div class="et_pb_module et_pb_text et_pb_text_2_tb_footer  et_pb_text_align_left et_pb_bg_layout_dark">
<div class="et_pb_text_inner"><p><span>© 2020 </span><a href="https://www.southkingmedia.com/">South King Media</a><span> | Powered by South King Media | <a href="https://b-townblog.com/privacy-policy-2/">Privacy Policy &amp; Terms</a></span></p></div>
</div> 
</div> 
</div> 
</div>  </div>
</footer>
</div>
</div> 
<span title="Back To Top" id="back_to_top"></span>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-cfasync='false'>window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','burien','burien-news-2','covid-19','crime','featured-post','news','police','burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released','post']</script>
<script data-cfasync='false'>window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["burien","burien-news-2","covid-19","crime","featured-post","news","police","burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released","post"],"url":"burien-police-detain-postal-thieves-recover-stolen-mail-alleged-covid-positive-suspect-released"};</script>
<script data-cfasync='false'>
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(6233);
 });</script> <script type="65e35b82932051ca2ab488f3-text/javascript">
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<script type="65e35b82932051ca2ab488f3-text/javascript">
				var et_link_options_data = [{"class":"et_pb_text_1_tb_footer","url":"https:\/\/b-townblog.com\/privacy-policy-terms-of-service\/","target":"_self"}];
			</script>
<script type="65e35b82932051ca2ab488f3-text/javascript"> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><link rel='stylesheet' id='tribe-events-custom-jquery-styles-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/the-events-calendar/vendor/jquery/smoothness/jquery-ui-1.8.23.custom.css?ver=5.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-bootstrap-datepicker-css-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/the-events-calendar/vendor/bootstrap-datepicker/css/bootstrap-datepicker.standalone.min.css?ver=5.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-events-calendar-style-css' href='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-full.min.css?ver=5.4.0' type='text/css' media='all' />
<script type="65e35b82932051ca2ab488f3-text/javascript" id='pushengage-core-js-before'>
window._peq = window._peq || []; window._peq.push(['init']);
</script>
<script type="65e35b82932051ca2ab488f3-text/javascript" async src='https://clientcdn.pushengage.com/core/49c8cebc-8ec8-4d2c-8119-b6008367.js?ver=5.6.2' id='pushengage-core-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/simple-posts-ticker/public/js/jquery.marquee.min.js?ver=1.5.0' id='spt-ticker-js-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/simple-posts-ticker/public/js/ticker.min.js?ver=1.1.5' id='spt-init-js-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.12.1' id='jquery-ui-menu-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/js/dist/dom-ready.min.js?ver=aca9d46a9f06d1759d4bcd73ba659133' id='wp-dom-ready-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/js/dist/i18n.min.js?ver=ac389435e7fd4ded01cf603f3aaba6a6' id='wp-i18n-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/js/dist/a11y.min.js?ver=410fc057d03809dd6a54fcc90ceca441' id='wp-a11y-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" id='jquery-ui-autocomplete-js-extra'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.12.1' id='jquery-ui-autocomplete-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" id='extra-scripts-js-extra'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/b-townblog.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/b-townblog.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"156f798b06","timeline_nonce":"b2205eb413","blog_feed_nonce":"54029c89f7","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"yes"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/b-townblog.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/b-townblog.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/b-townblog.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"6015069ac1","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"2e1c3469fe","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","wrong_checkbox":"Checkbox","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","ab_tests":[],"is_ab_testing_active":"","page_id":"150257","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"yes","is_shortcode_tracking":"","tinymce_uri":""}; var et_builder_utils_params = {"condition":{"diviTheme":false,"extraTheme":true},"scrollLocations":["app","top"],"builderScrollLocations":{"desktop":"app","tablet":"app","phone":"app"},"onloadScrollLocation":"app","builderType":"fe"}; var et_frontend_scripts = {"builderCssContainerPrefix":"#et-boc","builderCssLayoutPrefix":"#et-boc .et-l"};
var et_pb_box_shadow_elements = [];
var et_pb_motion_elements = {"desktop":[],"tablet":[],"phone":[]};
var et_pb_sticky_elements = [];
/* ]]> */
</script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/themes/Extra/scripts/scripts.unified.js?ver=4.9.0' id='extra-scripts-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/plugins/social-icons-widget-by-wpzoom/assets/js/social-icons-widget-frontend.js?ver=1611178814' id='zoom-social-icons-widget-frontend-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-content/themes/Extra/core/admin/js/common.js?ver=4.9.0' id='et-core-common-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=5.6.2' id='wp-embed-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" src='https://trinitymedia.ai/player/trinity.php?viewkey=696d3ce5ae748ca83d700f83c27748e8&#038;postHash=0f5b49cf96b2c2fefcb3418e5acc50e5&#038;poweredby=1&#038;language=en-US&#038;voiceGender=f&#038;ver=5.6.2' id='trinity-player-js'></script>
<script type="65e35b82932051ca2ab488f3-text/javascript" style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>
<script type="65e35b82932051ca2ab488f3-text/javascript">var _audins_dom="b_townblog_com",_audins_did=145975;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=192-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.b_townblog_com,DomainId.145975" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script><script type="65e35b82932051ca2ab488f3-text/javascript" onload="__ezcl.handle(true);" async src="/utilcave_com/inc/ezcl.webp?cb=4"></script><script src="https://ajax.cloudflare.com/cdn-cgi/scripts/7089c43e/cloudflare-static/rocket-loader.min.js" data-cf-settings="65e35b82932051ca2ab488f3-|49" defer=""></script><script type="text/javascript">(function(){window['__CF$cv$params']={r:'62a6b8a91ca5ea4d',m:'9620e9a016c7e040607668536b9b107d3d04679f-1614814946-1800-AYTVenHDDHKsDPOI4k0PR6a/XL9fg+lg7KApd7ndU5b47crWnUAhD/Pkbxl++uZzDzMq89ocQzr+fRyyMMo6/xMGCvdjkCNkmhzdLdgY2zEBr+J+zRDKcOxQdm6VNyBimFUmwBRxT34IbIsKOHiZv0Idggefs8wlwaegaDGKLDbEkSnJ7Vs2DYMdBdU4vdEuTVoukcnwup9OSYQaqkGncLpqqK/UYiPw8+HyDs+CtX1ee2/MfB1a4fT68Gix1ugMVA==',s:[0xd960deb058,0x33dcd49716],}})();</script></body>
</html>








