<!DOCTYPE html><html lang="en-US" prefix="og: https://ogp.me/ns#"><head><meta charset="UTF-8" />
<script src="/cdn-cgi/apps/head/1A0EzwKI42LNED2YhGMFOvfir40.js"></script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=194-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=194-0&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=194-0&cb=5', false, [], true, false, true, false);</script>
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<link rel="pingback" href="https://b-townblog.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://b-townblog.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->
<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>
<script>var et_site_url='https://b-townblog.com';var et_post_id='150657';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script>

<title>Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4 - The B-Town (Burien) Blog</title>
<meta name="description" content="From our friends at WABI Burien:" />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4 - The B-Town (Burien) Blog" />
<meta property="og:description" content="From our friends at WABI Burien:" />
<meta property="og:url" content="https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/" />
<meta property="og:site_name" content="The B-Town (Burien) Blog" />
<meta property="article:publisher" content="https://www.facebook.com/btownblog/" />
<meta property="article:tag" content="Burien" />
<meta property="article:tag" content="health" />
<meta property="article:tag" content="indian trail" />
<meta property="article:tag" content="news" />
<meta property="article:tag" content="talk" />
<meta property="article:tag" content="Three Tree Point" />
<meta property="article:tag" content="WABI Burien" />
<meta property="article:tag" content="walk" />
<meta property="article:tag" content="walk-n-talk" />
<meta property="article:tag" content="walking" />
<meta property="article:section" content="Burien" />
<meta property="og:updated_time" content="2021-04-03T11:21:23-07:00" />
<meta property="og:image" content="https://b-townblog.com/wp-content/uploads/2019/11/BTB-Walk-n-Talk19.jpg" />
<meta property="og:image:secure_url" content="https://b-townblog.com/wp-content/uploads/2019/11/BTB-Walk-n-Talk19.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="640" />
<meta property="og:image:alt" content="Walk-n-Talk" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4 - The B-Town (Burien) Blog" />
<meta name="twitter:description" content="From our friends at WABI Burien:" />
<meta name="twitter:site" content="@btownblog" />
<meta name="twitter:creator" content="@btownblog" />
<meta name="twitter:image" content="https://b-townblog.com/wp-content/uploads/2019/11/BTB-Walk-n-Talk19.jpg" />
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":"Place","@id":"https://b-townblog.com/#place"},{"@type":["NewsMediaOrganization","Organization"],"@id":"https://b-townblog.com/#organization","name":"South King Media","url":"https://b-townblog.com","email":"editor@b-townblog.com","logo":{"@type":"ImageObject","url":"https://b-townblog.com/wp-content/uploads/2019/08/btown_logo.png","caption":"South King Media","inLanguage":"en-US","width":"242","height":"89"},"contactPoint":[{"@type":"ContactPoint","telephone":"1-206-248-2565","contactType":"customer support"}],"location":{"@id":"https://b-townblog.com/#place"}},{"@type":"WebSite","@id":"https://b-townblog.com/#website","url":"https://b-townblog.com","name":"South King Media","publisher":{"@id":"https://b-townblog.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/#primaryImage","url":"https://b-townblog.com/wp-content/uploads/2019/11/BTB-Walk-n-Talk19.jpg","width":"1280","height":"640","inLanguage":"en-US"},{"@type":"BreadcrumbList","@id":"https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/#breadcrumb","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"https://b-townblog.com","name":"Home"}},{"@type":"ListItem","position":"2","item":{"@id":"https://b-townblog.com/category/burien/","name":"Burien"}},{"@type":"ListItem","position":"3","item":{"@id":"https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/","name":"Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4"}}]},{"@type":"Person","@id":"https://b-townblog.com/author/scottschaefer/","name":"Scott Schaefer","image":{"@type":"ImageObject","url":"https://secure.gravatar.com/avatar/488f3b70570d89090bbe6fdcc9b8ed10?s=96&amp;d=mm&amp;r=g","caption":"Scott Schaefer","inLanguage":"en-US"},"sameAs":["https://www.b-townblog.com"],"worksFor":{"@id":"https://b-townblog.com/#organization"}},{"@type":"WebPage","@id":"https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/#webpage","url":"https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/","name":"Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4 - The B-Town (Burien) Blog","datePublished":"2021-04-03T11:08:31-07:00","dateModified":"2021-04-03T11:21:23-07:00","author":{"@id":"https://b-townblog.com/author/scottschaefer/"},"isPartOf":{"@id":"https://b-townblog.com/#website"},"primaryImageOfPage":{"@id":"https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/#primaryImage"},"inLanguage":"en-US","breadcrumb":{"@id":"https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/#breadcrumb"}},{"@type":"NewsArticle","headline":"Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4 - The B-Town (Burien) Blog","keywords":"Walk-n-Talk,Indian Trail,walk,talk,Burien","datePublished":"2021-04-03T11:08:31-07:00","dateModified":"2021-04-03T11:21:23-07:00","author":{"@type":"Person","name":"Scott Schaefer"},"publisher":{"@id":"https://b-townblog.com/#organization"},"description":"From our friends at WABI Burien:","name":"Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4 - The B-Town (Burien) Blog","@id":"https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/#richSnippet","isPartOf":{"@id":"https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/#webpage"},"image":{"@id":"https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/#primaryImage"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/#webpage"}}]}</script>

<link rel="dns-prefetch" href="//cdn.broadstreetads.com" />
<link rel="dns-prefetch" href="//clientcdn.pushengage.com" />
<link rel="dns-prefetch" href="//fonts.googleapis.com" />
<link rel="dns-prefetch" href="//ad.broadstreetads.com" />
<link rel="dns-prefetch" href="//cdn-images.mailchimp.com" />
<link rel="dns-prefetch" href="//cdnjs.cloudflare.com" />
<link rel="dns-prefetch" href="//fonts.gstatic.com" />
<link rel="dns-prefetch" href="//google-analytics.com" />
<link rel="dns-prefetch" href="//google.com" />
<link rel="dns-prefetch" href="//googletagmanager.com" />
<link rel="dns-prefetch" href="//maps.googleapis.com" />
<link rel="dns-prefetch" href="//red.broadstreetads.com" />
<link rel="dns-prefetch" href="//scontent.xx.fbcdn.net" />
<link rel="dns-prefetch" href="//2ej0gbn74ih1bkkbncdbdpn0-wpengine.netdna-ssl.com" />
<link href="https://fonts.gstatic.com" crossorigin="" rel="preconnect" />
<link rel="alternate" type="application/rss+xml" title="The B-Town (Burien) Blog » Feed" href="https://b-townblog.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The B-Town (Burien) Blog » Comments Feed" href="https://b-townblog.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="The B-Town (Burien) Blog » iCal Feed" href="https://b-townblog.com/events/?ical=1" />
<meta content="Extra v.4.9.3" name="generator" /><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel="stylesheet" id="tribe-common-skeleton-style-css" href="https://b-townblog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css?ver=4.13.0" type="text/css" media="all" />
<link rel="stylesheet" id="tribe-tooltip-css" href="https://b-townblog.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css?ver=4.13.0" type="text/css" media="all" />
<link rel="stylesheet" id="wp-block-library-css" href="https://b-townblog.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7" type="text/css" media="all" />
<link crossorigin="anonymous" rel="stylesheet" id="wpb-google-fonts-css" href="//fonts.googleapis.com/css?family=Open+Sans&amp;ver=5.7" type="text/css" media="all" />
<link rel="stylesheet" id="weather-atlas-css" href="https://b-townblog.com/wp-content/plugins/weather-atlas/public/css/weather-atlas-public.min.css?ver=1.2.1" type="text/css" media="all" />
<link rel="stylesheet" id="weather-icons-css" href="https://b-townblog.com/wp-content/plugins/weather-atlas/public/font/weather-icons/weather-icons.min.css?ver=1.2.1" type="text/css" media="all" />
<link crossorigin="anonymous" rel="stylesheet" id="extra-fonts-css" href="https://fonts.googleapis.com/css?family=Open+Sans:300italic,400italic,600italic,700italic,800italic,400,300,600,700,800&amp;subset=latin,latin-ext" type="text/css" media="all" />
<link rel="stylesheet" id="extra-style-css" href="https://b-townblog.com/wp-content/themes/Extra/style.css?ver=4.9.3" type="text/css" media="all" />
<link rel="stylesheet" id="dashicons-css" href="https://b-townblog.com/wp-includes/css/dashicons.min.css?ver=5.7" type="text/css" media="all" />
<style id="rocket-lazyload-inline-css" type="text/css">
.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%;}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://b-townblog.com/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}
</style>
<script type="text/javascript" data-cfasync="false" src="//cdn.broadstreetads.com/init-2.min.js?ver=5.7" id="broadstreet-cdn-js"></script>
<script type="text/javascript" src="https://b-townblog.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1" id="jquery-core-js"></script>
<script type="text/javascript" src="https://b-townblog.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2" id="jquery-migrate-js"></script>
<script type="text/javascript" src="https://b-townblog.com/wp-content/plugins/weather-atlas/public/js/weather-atlas-public.min.js?ver=1.2.1" id="weather-atlas-js"></script>
<script type="text/javascript" src="https://b-townblog.com/wp-content/plugins/weather-atlas/public/js/jquery-cookie.min.js?ver=1.2.1" id="jquery-cookie-js"></script>
<link rel="https://api.w.org/" href="https://b-townblog.com/wp-json/" /><link rel="alternate" type="application/json" href="https://b-townblog.com/wp-json/wp/v2/posts/150657" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://b-townblog.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://b-townblog.com/wp-includes/wlwmanifest.xml" />
<link rel="shortlink" href="https://b-townblog.com/?p=150657" />
<link href="https://trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<link href="https://vd.trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<meta name="tec-api-version" content="v1" /><meta name="tec-api-origin" content="https://b-townblog.com" /><link rel="https://theeventscalendar.com/" href="https://b-townblog.com/wp-json/tribe/events/v1/" /><meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><link rel="shortcut icon" href="https://b-townblog.com/wp-content/uploads/2020/09/BTBFavicon2.jpg" /><link rel="preload" href="https://b-townblog.com/wp-content/themes/Extra/core/admin/fonts/modules.ttf" as="font" crossorigin="anonymous" /><link rel="amphtml" href="https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/amp/" />
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-W3XBHN9');</script>


<meta name="msvalidate.01" content="7E1E96B84AE8370D63E4DCDCA37E5772" /><meta property="fb:pages" content="26665821728" /><link rel="preload" content="/wp-content/uploads/2020/05/btown_logoSKM20d.png" as="image" media="(max-width: 242px)" /><link rel="preload" href="/wp-content/themes/Extra/core/admin/fonts/modules.ttf" as="font" type="font/ttf" /><link rel="preload" href="https://fonts.gstatic.com/s/opensans/v18/mem5YaGs126MiZpBA-UN7rgOUuhpKKSTjw.woff2" as="font" type="font/woff2" crossorigin="" /><link rel="preload" href="https://fonts.gstatic.com/s/opensans/v18/mem8YaGs126MiZpBA-UFVZ0bf8pkAg.woff2" as="font" type="font/woff2" crossorigin="" /><link rel="preload" href="https://fonts.gstatic.com/s/opensans/v18/mem5YaGs126MiZpBA-UNirkOUuhpKKSTjw.woff2" as="font" type="font/woff2" crossorigin="" /><link rel="preload" href="https://fonts.gstatic.com/s/opensans/v18/mem5YaGs126MiZpBA-UN7rgOUuhpKKSTjw.woff2" as="font" type="font/woff2" crossorigin="" /><link rel="preload" href="/wp-includes/js/jquery/jquery.min.js?ver=3.5.1" as="script" /><meta property="fb:pages" content="26665821728" /><link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://b-townblog.com/wp-content/et-cache/global/et-extra-customizer-global-161738525083.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script type="text/javascript">var ezouid = "1";</script><base href="https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/"><script type='text/javascript'>
var ezoTemplate = 'old_site_noads';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script>
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 145975;
var ezdomain = 'b-townblog.com';
var ezoicSearchable = 1;
</script>


<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":145975,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"0f9f76b7-034e-4562-7a3c-85bfb5cd2ccd","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":96165,"response_time_orig":5,"serverid":"34.224.167.210:12306","state":"VA","t_epoch":1617479963,"template_id":120,"time_on_site_visit":0,"url":"https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/","user_id":0,"word_count":1078,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script src="//www.ezojs.com/ezoic/ezd.js" defer async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_145975=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["0f9f76b7-034e-4562-7a3c-85bfb5cd2ccd", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script><script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body class="post-template-default single single-post postid-150657 single-format-standard et-tb-has-template et-tb-has-header et-tb-has-footer tribe-no-js et_extra et_fullwidth_nav et_fullwidth_secondary_nav et_non_fixed_nav et_pb_gutters4 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar et-db et_minified_js et_minified_css">
<div id="page-container" class="page-container">
<div id="et-boc" class="et-boc">
<header class="et-l et-l--header">
<div class="et_builder_inner_content et_pb_gutters4">
<div id="pp-banner" class="et_pb_section et_pb_section_0_tb_header et_pb_with_background et_section_regular">
</div> <div class="et_pb_section et_pb_section_1_tb_header et_pb_with_background et_section_regular">
<div class="et_pb_row et_pb_row_0_tb_header et_pb_row--with-menu">
<div class="et_pb_column et_pb_column_2_5 et_pb_column_0_tb_header  et_pb_css_mix_blend_mode_passthrough et_pb_column--with-menu">
<div class="et_pb_module et_pb_menu et_pb_menu_0_tb_header et_pb_bg_layout_dark  et_pb_text_align_left et_dropdown_animation_fade et_pb_menu--without-logo et_pb_menu--style-left_aligned">
<div class="et_pb_menu_inner_container clearfix">
<div class="et_pb_menu__wrap">
<div class="et_pb_menu__menu">
<nav class="et-menu-nav"><ul id="menu-secondary-1-7-20" class="et-menu nav"><li id="menu-item-144432" class="et_pb_menu_page_id-143239 menu-item menu-item-type-post_type menu-item-object-page menu-item-144432"><a href="https://b-townblog.com/subscribe-to-our-free-daily-newsletter/">Newsletter</a></li>
<li id="menu-item-144429" class="et_pb_menu_page_id-136106 menu-item menu-item-type-post_type menu-item-object-page menu-item-144429"><a href="https://b-townblog.com/advertise/">Advertise</a></li>
<li id="menu-item-144433" class="et_pb_menu_page_id-135114 menu-item menu-item-type-post_type menu-item-object-page menu-item-144433"><a href="https://b-townblog.com/how-to-submit-to-the-blog/">Submit</a></li>
<li id="menu-item-144430" class="et_pb_menu_page_id-43 menu-item menu-item-type-post_type menu-item-object-page menu-item-144430"><a href="https://b-townblog.com/about/">About</a></li>
<li id="menu-item-144431" class="et_pb_menu_page_id-78 menu-item menu-item-type-post_type menu-item-object-page menu-item-144431"><a href="https://b-townblog.com/contact/">Contact</a></li>
</ul></nav>
</div>
<div class="et_mobile_nav_menu">
<a href="#" class="mobile_nav closed">
<span class="mobile_menu_bar"></span>
</a>
</div>
</div>
</div>
</div>
</div> <div class="et_pb_column et_pb_column_3_5 et_pb_column_1_tb_header  et_pb_css_mix_blend_mode_passthrough et-last-child">
<div class="et_pb_module et_pb_code et_pb_code_0_tb_header">
<div class="et_pb_code_inner"><broadstreet-zone zone-id="72549"></broadstreet-zone></div>
</div> 
</div> 
</div> 
</div> <div class="et_pb_section et_pb_section_2_tb_header et_pb_with_background et_section_regular">
<div class="et_pb_row et_pb_row_1_tb_header et_pb_row--with-menu">
<div class="et_pb_column et_pb_column_4_4 et_pb_column_2_tb_header  et_pb_css_mix_blend_mode_passthrough et-last-child et_pb_column--with-menu">
<div class="et_pb_module et_pb_menu et_pb_menu_1_tb_header et_pb_bg_layout_dark  et_pb_text_align_right et_dropdown_animation_fade et_pb_menu--with-logo et_pb_menu--style-left_aligned">
<div class="et_pb_menu_inner_container clearfix">
<div class="et_pb_menu__logo-wrap">
<div class="et_pb_menu__logo">
<a href="https://b-townblog.com/"><img src="https://b-townblog.com/wp-content/uploads/2020/05/btown_logoSKM20d.png" alt="" height="auto" width="auto" class="wp-image-146891" /></a>
</div>
</div>
<div class="et_pb_menu__wrap">
<div class="et_pb_menu__menu">
<nav class="et-menu-nav"><ul id="menu-primary-1-7-20" class="et-menu nav"><li id="menu-item-144435" class="et_pb_menu_page_id-144435 menu-item menu-item-type-custom menu-item-object-custom menu-item-144435"><a href="https://b-townblog.com/events/">Events</a></li>
<li id="menu-item-144436" class="et_pb_menu_page_id-50 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144436"><a href="https://b-townblog.com/category/crime/">Crime</a></li>
<li id="menu-item-150397" class="et_pb_menu_page_id-48 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-150397"><a href="https://b-townblog.com/category/politics/">Politics</a></li>
<li id="menu-item-146171" class="et_pb_menu_page_id-146171 menu-item menu-item-type-custom menu-item-object-custom menu-item-146171"><a href="https://b-townblog.com/category/covid-19/">COVID-19</a></li>
<li id="menu-item-144776" class="et_pb_menu_page_id-144776 menu-item menu-item-type-custom menu-item-object-custom menu-item-144776"><a href="https://b-townblog.com/jobs/">Jobs</a></li>
<li id="menu-item-144439" class="et_pb_menu_page_id-8 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144439"><a href="https://b-townblog.com/category/arts/">Arts</a></li>
<li id="menu-item-144441" class="et_pb_menu_page_id-37 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144441"><a href="https://b-townblog.com/category/business/">Business</a></li>
<li id="menu-item-150542" class="et_pb_menu_page_id-135305 menu-item menu-item-type-post_type menu-item-object-page menu-item-150542"><a href="https://b-townblog.com/weather/">Weather</a></li>
<li id="menu-item-150602" class="et_pb_menu_page_id-150444 menu-item menu-item-type-post_type menu-item-object-page menu-item-150602"><a href="https://b-townblog.com/webcams/">Webcams</a></li>
<li id="menu-item-144449" class="et_pb_menu_page_id-144449 menu-item menu-item-type-custom menu-item-object-custom menu-item-144449"><a target="_blank" rel="noopener" href="https://burien.bhhsnwrealestate.com"><img src="https://b-townblog.com/wp-content/uploads/2019/10/BHHSLogoforMenu167x69.png" align="top" alt="Berkshire Hathaway HomeServices Northwest Realty" width="152" height="52" /></a></li>
</ul></nav>
</div>
<div class="et_mobile_nav_menu">
<a href="#" class="mobile_nav closed">
<span class="mobile_menu_bar"></span>
</a>
</div>
</div>
</div>
</div>
</div> 
</div> 
</div>  </div>
</header>
<div id="main-content">
<div class="container">
<div id="content-area" class="clearfix">
<div class="et_pb_extra_column_main">
<center><em>If you appreciate our award-winning local journalism, please…</em>
<div class="pp-donate-button"></div></center> <article id="post-150657" class="module single-post-module post-150657 post type-post status-publish format-standard has-post-thumbnail hentry category-burien category-burien-news-2 category-events category-featured-post category-health-wellness category-news category-sports tag-burien tag-health tag-indian-trail tag-news tag-talk tag-three-tree-point tag-wabi-burien tag-walk tag-walk-n-talk tag-walking et-has-post-format-content et_post_format-et-post-format-standard">
<div class="post-header">
<h1 class="entry-title">Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4</h1>
<div class="post-meta vcard">
<p><span class="updated">Apr 3, 2021</span> | <a href="https://b-townblog.com/category/burien/" rel="tag">Burien</a>, <a href="https://b-townblog.com/category/burien-news-2/" rel="tag">Burien News</a>, <a href="https://b-townblog.com/category/events/" rel="tag">Events</a>, <a href="https://b-townblog.com/category/featured-post/" rel="tag">Featured Post</a>, <a href="https://b-townblog.com/category/health-wellness/" rel="tag">Health &amp; Wellness</a>, <a href="https://b-townblog.com/category/news/" rel="tag">News</a>, <a href="https://b-townblog.com/category/sports/" rel="tag">Sports</a></p>
</div>
</div>
<div class="post-thumbnail header">
<img src="https://b-townblog.com/wp-content/uploads/2019/11/BTB-Walk-n-Talk19.jpg" alt="Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4" /> </div>
<div class="post-wrap">
<div class="post-content entry-content">
<table id="trinity-audio-table" style="width:100%; display: table;">
<tbody><tr>
<td id="trinity-audio-tab" style="border: none;">
<div id="trinity-audio-player-label"></div>
<script>var TRINITY_TTS_WP_CONFIG = {"cleanText":"Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4. From our friends at WABI Burien:\r\n\r\nOne of Burien\u2019s outdoor gems is the \u201cIndian Trail\u201d.\r\nThis wandering, varied trail winds high above the shoreline strip of SW 172nd St. \u2013 the \u201cSunrise Trail\u201d \u2013 \u00a0and then, from Three Tree Point northward, parallels Maplewild Ave. SW \u2013 the \u201cSunset Trail\u201d. It is said to be the remnant of a trail used long ago by the local Native American tribes in the region as they traveled from the south end of Puget Sound to the north. Some portions of the trail are heavily-wooded and lush green. Other areas are wide open to the sky. There are three public beach access points along the way.\r\n\u201dWABI\u00a0would like to acknowledge that we will be on the traditional land of the first people of Seattle, the Duwamish People past and present, and honor, with gratitude, the land itself and the Duwamish Tribe.\u201d \r\nWe have typically walked this trail in July, on blazing hot days. A spring day, instead, should be cool and lovely. On Sunday, April 4, 2021, our monthly Walk-n-Talk starts cliff-high in Gregory Heights, winds down to Three Tree Point, then back up\u00a0to Maplewild, at the 16000 block. At one point along the way, there is a 180 degree view of Normandy Park, Des Moines, Redondo, Mt. Rainier, Tacoma, the islands of Puget Sound and the Olympic Mountains. We then turn around, retrace our steps and go back UP the hill to our starting point!\r\n\r\nThis is a FREE event and open to all (that can handle the terrain of the trail), including friendly four-legged friends.\r\n\r\n\r\nMt. Rainier, as see from the \u201cSunrise\u201d portion of the Indian Trail.\r\n\r\n\r\n \tDate: Sunday, April 4, 2021, rain or shine. (a water bottle is a great idea on this trail.)\r\n \tTime: 2:00 meet-up. Walking starts at 2:15\r\n \tPlace: Meet at the corner of \u00a0SW\u00a0167th Place and 31st Ave. SW (NOT at Burien Town Square.)\r\nThis is in the Gregory Heights neighborhood above Three Tree Point.\r\n \tRoute & Distance: We start UP in Gregory Heights, go DOWN to Three Tree Point, UP partway on Maplewild, then turn around and go back down to the Point and back up to Gregory heights. The total is about 3 miles, round trip. The elevation change is about 300 feet.\r\n \tParking: There is parking on the street in the Gregory Heights neighborhood, near the starting point. (Public parking along Maplewild is difficult to find.) As always, please be respectful of private property when parking your car.\r\n \tNOTE \u2013 Trail Terrain:\u00a0This is a beautiful walk, paved wide in places, a narrow dirt path in others. Please be advised that this trip has quite an elevation change going down the hill and then back up. The path is also quite rugged and irregular in places. Because of these factors, it\u2019s a poor choice for those with health and mobility limitations, and the trail will not accommodate strollers for children.\r\n\r\nAs with all of our walks, walkers may choose to do all or just part of the route. And walkers may always walk at whatever pace is most comfortable for them.\r\n\r\nIf you do not want to walk back up the hill to the starting point, but would rather finish at the Maplewild end, we suggest that you carpool\u00a0with a friend, leave the first\u00a0car somewhere along Maplewild (or within walking distance), and then drive the second\u00a0car to the starting point. At the end of the walk, you can hop into the first car and go back and get the second car.\r\n\r\nFor further information, please contact\u00a0Maureen Hoffmann at\u00a0info@wabiburien.org.\r\n\r\n\r\n\r\nThe sweeping view, in evening along the \u201cSunrise\u201d portion of the Indian Trail. (click the photo for a larger view.)\r\n\r\n\r\n\r\nWhen standing on the \u201cSunset\u201d part of the Indian Trail, which parallels Maplewild, one can look northwest toward Seahurst Beach, Shorewood and beyond, toward West Seattle.\r\n\r\nClick on the map below and print a copy to take with you on the walk:\r\n\r\n\r\n\u00a0\r\n","pluginVersion":"3.0.4"};</script><div class="trinityAudioPlaceholder"></div>
</td>
</tr>
</tbody></table><script>console.debug('TRINITY_WP', 'trinity_content_filter');</script><blockquote><p><strong>From our friends at <a href="https://wabiburien.org/springtime-walk-n-talk-on-the-indian-trail-april-4/" target="_blank" rel="noopener">WABI Burien</a>:</strong></p></blockquote>
<h3 style="text-align: center;"><strong>One of Burien’s outdoor gems is the “Indian Trail”.</strong></h3>
<p>This wandering, varied trail winds high above the shoreline strip of SW 172nd St. – the “Sunrise Trail” –  and then, from Three Tree Point northward, parallels Maplewild Ave. SW – the “Sunset Trail”. It is said to be the remnant of a trail used long ago by the local Native American tribes in the region as they traveled from the south end of Puget Sound to the north. Some portions of the trail are heavily-wooded and lush green. Other areas are wide open to the sky. There are three public beach access points along the way.</p>
<p style="padding-left: 40px;"><strong>”WABI <em>would like to acknowledge that we will be on the traditional land of the first people of Seattle, the Duwamish People past and present, and honor, with gratitude, the land itself and the Duwamish Tribe.” </em></strong></p>
<p>We have typically walked this trail in July, on blazing hot days. A spring day, instead, should be cool and lovely. On <strong>Sunday, April 4, 2021</strong>, our monthly Walk-n-Talk starts cliff-high in Gregory Heights, winds down to Three Tree Point, then back up to Maplewild, at the 16000 block. At one point along the way, there is a 180 degree view of Normandy Park, Des Moines, Redondo, Mt. Rainier, Tacoma, the islands of Puget Sound and the Olympic Mountains. We then turn around, retrace our steps and <strong>go back UP the hill</strong> to our starting point!</p>
<p>This is a <strong>FREE event</strong> and open to all (that can handle the terrain of the trail), including friendly four-legged friends.</p>
<p></p><center><a href="http://www.wabiburien.org/wp-content/uploads/2012/05/Mt.RainierSpringLO.jpg" target="_blank" rel="noopener"><img class=" wp-image-783" title="Mt.RainierSpringLO" src="http://www.wabiburien.org/wp-content/uploads/2012/05/Mt.RainierSpringLO.jpg" sizes="(max-width: 560px) 100vw, 560px" srcset="https://wabiburien.org/wp-content/uploads/2012/05/Mt.RainierSpringLO.jpg 800w, https://wabiburien.org/wp-content/uploads/2012/05/Mt.RainierSpringLO-300x207.jpg 300w" alt="Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4 1" width="560" height="388" aria-describedby="caption-attachment-783" /></a></center><p></p>
<p id="caption-attachment-783" class="wp-caption-text">Mt. Rainier, as see from the “Sunrise” portion of the Indian Trail.</p>
<ul>
<li><strong>Date</strong>: Sunday, April 4, 2021, rain or shine. (a water bottle is a great idea on this trail.)</li>
<li><strong>Time</strong>: 2:00 meet-up. Walking starts at 2:15</li>
<li><strong>Place</strong>: Meet at the corner of  SW 167th Place and 31st Ave. SW (<strong>NOT at Burien Town Square.</strong>)<br />
This is in the Gregory Heights neighborhood above Three Tree Point.</li>
<li><strong>Route &amp; Distance</strong>: We start UP in Gregory Heights, go DOWN to Three Tree Point, UP partway on Maplewild, then turn around and go back down to the Point and back up to Gregory heights. The total is about 3 miles, round trip. The elevation change is about 300 feet.</li>
<li><strong>Parking</strong>: There is parking on the street in the Gregory Heights neighborhood, near the starting point. (Public parking along Maplewild is difficult to find.) As always, please be respectful of private property when parking your car.</li>
<li><strong>NOTE – Trail Terrain</strong>: This is a beautiful walk, paved wide in places, a narrow dirt path in others. Please be advised that this trip has quite an elevation change going down the hill and then back up. The path is also quite rugged and irregular in places. Because of these factors, <strong>it’s a poor choice for those with health and mobility limitations, and the trail will not accommodate strollers for children</strong>.</li>
</ul>
<p>As with all of our walks, walkers may choose to do all or just part of the route. And walkers may always walk at whatever pace is most comfortable for them.</p>
<p>If you do not want to walk back up the hill to the starting point, but would rather finish at the Maplewild end, we suggest that you carpool with a friend, leave the first car somewhere along Maplewild (or within walking distance), and then drive the second car to the starting point. At the end of the walk, you can hop into the first car and go back and get the second car.</p>
<p>For further information, please contact Maureen Hoffmann at <strong><a href="/cdn-cgi/l/email-protection#89e0e7efe6c9fee8ebe0ebfcfbe0ece7a7e6fbee"><span class="__cf_email__" data-cfemail="a5cccbc3cae5d2c4c7ccc7d0d7ccc0cb8bcad7c2">[email&#160;protected]</span></a></strong>.</p>
<p><a href="http://www.wabiburien.org/wp-content/uploads/2012/05/Sundown-Trail-Walk-Pano.jpg" target="_blank" rel="noopener"><img src="http://www.wabiburien.org/wp-content/uploads/2012/05/Sundown-Trail-Walk-Pano.jpg" alt="Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4 2" width="1100" height="169" title="Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4 1" /></a></p>
<p><em>The sweeping view, in evening along the “Sunrise” portion of the Indian Trail. (click the photo for a larger view.)</em></p>
<p><img src="http://www.wabiburien.org/wp-content/uploads/2016/06/Indian-Trail-Walk-1.jpg" alt="Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4 3" width="960" height="720" title="Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4 2" /></p>
<p><em>When standing on the “Sunset” part of the Indian Trail, which parallels Maplewild, one can look northwest toward Seahurst Beach, Shorewood and beyond, toward West Seattle.</em></p>
<p><strong>Click on the map below and print a copy to take with you on the walk:</strong></p>
<p><a href="http://www.wabiburien.org/wp-content/uploads/2012/05/WABI-Indian-Trail-Walk.jpg" target="_blank" rel="noopener"><img class="aligncenter size-large" src="http://www.wabiburien.org/wp-content/uploads/2012/05/WABI-Indian-Trail-Walk.jpg" width="1000" height="800" alt="Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4 4" title="Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4 3" /></a><br />
 </p>
<div style="margin:5px auto; margin-bottom: 15px;" id="zone_load_1178174212"><broadstreet-zone callback="zone_load_1178174212" zone-id="72541" keywords="not_home_page,not_landing_page,is_article_page,burien,burien-news-2,events,featured-post,health-wellness,news,sports,springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4,post" soft-keywords="true" zone-alias=""></broadstreet-zone></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>window.zone_load_1178174212 = function(z, d) { if (!d.count) document.getElementById('zone_load_1178174212').style.display = 'none'; };</script> </div>
</div>
<div class="post-footer">
<div class="social-icons ed-social-share-icons">
<p class="share-title">Share:</p>
<a href="https://www.facebook.com/sharer.php?u=https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/&amp;t=Springtime%20Walk-n-Talk%20on%20the%20Indian%20Trail%20this%20Sunday%2C%20April%204" class="social-share-link" title="Share &#34;Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4&#34; via Facebook" data-network-name="facebook" data-share-title="Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4" data-share-url="https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/">
<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover"></span>
</a><a href="https://twitter.com/intent/tweet?text=Springtime%20Walk-n-Talk%20on%20the%20Indian%20Trail%20this%20Sunday%2C%20April%204%20https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/" class="social-share-link" title="Share &#34;Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4&#34; via Twitter" data-network-name="twitter" data-share-title="Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4" data-share-url="https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/">
<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover"></span>
 </a><a href="#" class="social-share-link" title="Share &#34;Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4&#34; via Email" data-network-name="basic_email" data-share-title="Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4" data-share-url="https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/">
<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover"></span>
</a><a href="#" class="social-share-link" title="Share &#34;Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4&#34; via Print" data-network-name="basic_print" data-share-title="Springtime Walk-n-Talk on the Indian Trail this Sunday, April 4" data-share-url="https://b-townblog.com/2021/04/03/springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4/">
<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover"></span>
</a> </div>
<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #669933;
									}
								</style>
</div>
</article>
<nav class="post-nav">
<div class="nav-links clearfix">
<div class="nav-link nav-link-prev">
<a href="https://b-townblog.com/2021/04/02/volunteers-needed-for-discover-buriens-clean-sweep-returning-saturday-april-24/" rel="prev"><span class="button">Previous</span><span class="title">Volunteers needed for Discover Burien’s Clean Sweep, returning Saturday, April 24</span></a> </div>
<div class="nav-link nav-link-next">
</div>
</div>
</nav>
<center><div class="pp-donate-button"></div></center>
 

<link href="//cdn-images.mailchimp.com/embedcode/slim-10_7.css" rel="stylesheet" type="text/css" /><style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif;  width:500px;}
	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style><div id="mc_embed_signup">
<form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=af702f1850" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate="">
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Subscribe to our FREE Daily Digest Email!</label>
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required="" /><div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_af702f1850" tabindex="-1" value="" /></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button" /></div>
</div>
</form>
</div>

</div>
<div class="et_pb_extra_column_sidebar">
<div id="search-3" class="et_pb_widget widget_search"><h4 class="widgettitle">Search The B-Town (Burien) Blog</h4><form role="search" method="get" class="search-form" action="https://b-townblog.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search …" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div> <div id="custom_html-2" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle">Support Our Sponsors</h4><div class="textwidget custom-html-widget"><center><broadstreet-zone zone-id="72555"></broadstreet-zone></center></div></div> <div id="custom_html-5" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"> </h4><div class="textwidget custom-html-widget"><center><broadstreet-zone zone-id="76533"></broadstreet-zone></center></div></div> <div id="custom_html-3" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"> </h4><div class="textwidget custom-html-widget"><center><broadstreet-zone zone-id="72575"></broadstreet-zone></center></div></div> <div id="custom_html-4" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"> </h4><div class="textwidget custom-html-widget"><center><broadstreet-zone zone-id="72685"></broadstreet-zone></center></div></div> <div id="text-18" class="et_pb_widget widget_text"><h4 class="widgettitle">2021 CANDIDATE’S GUIDE</h4> <div class="textwidget"><p><a href="https://b-townblog.com/2021/02/17/think-youd-be-a-better-burien-city-councilmember-heres-how-you-can-run-for-office/"><img class="aligncenter size-full wp-image-145675" src="https://b-townblog.com/wp-content/uploads/2021/02/BTB-CandidatesGuide2021.jpg" alt="" width="300" height="100" /></a></p>
</div>
</div> <div id="text-14" class="et_pb_widget widget_text"><h4 class="widgettitle">SUPPORT LOCAL RESTAURANTS</h4> <div class="textwidget"><p><a href="https://b-townblog.com/2020/03/17/support-our-local-restaurants-during-the-quarantine-heres-how-where-to-order-food/"><img class="aligncenter size-full wp-image-145722" src="https://b-townblog.com/wp-content/uploads/2020/03/SupportLocalRestaurants300x150WidgetArt.jpg" alt="" width="300" height="150" /></a></p>
</div>
</div> <div id="text-16" class="et_pb_widget widget_text"><h4 class="widgettitle">SUPPORT BLACK-OWNED BUSINESSES</h4> <div class="textwidget"><p><a href="https://b-townblog.com/2020/06/05/heres-how-you-can-support-local-black-owned-businesses/"><img class="aligncenter size-full wp-image-147112" src="https://b-townblog.com/wp-content/uploads/2020/06/SupportBlackBusinesses300x150WidgetArt.jpg" alt="" width="300" height="150" /></a></p>
</div>
</div> <div id="custom_html-6" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"> </h4><div class="textwidget custom-html-widget"><center><broadstreet-zone zone-id="72704"></broadstreet-zone></center></div></div> <div id="search-4" class="et_pb_widget widget_search"><h4 class="widgettitle">Search The B-Town Blog</h4><form role="search" method="get" class="search-form" action="https://b-townblog.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search …" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form></div> <div id="media_image-2" class="et_pb_widget widget_media_image"><h4 class="widgettitle">SUPPORT LOCAL JOURNALISM</h4><a href="https://b-townblog.com/support-local-journalism/"><img width="300" height="250" src="https://b-townblog.com/wp-content/uploads/2020/05/BTBSupportAd300x250-2SPJ.jpg" class="image wp-image-146836  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" title="SUPPORT LOCAL JOURNALISM" /></a></div> <div id="weather_atlas-3" class="et_pb_widget widget_weather_atlas"><h4 class="widgettitle">WEATHER</h4><div class="weather-atlas-wrapper" style="background:#669933;border:1px solid #558822;color:#fff;"><div class="weather-atlas-header" style="border-bottom:1px solid #558822"><div class="weather-atlas-header-title-wrapper"><div class="weather-atlas-header-title">Burien</div><div class="city_selector_toggle_div autocomplete" style="display:none;"><script>/*<![CDATA[*/var weather_atlas_language = 'en';/*]]>*/</script><input class="city_name" id="city_name" name="city_name" type="text" value="" placeholder="type and select location from drop-down" /></div></div><div class="city_selector_toggle"><a href="#" class="city_selector_toggle_link" style="color:#fff" title="Location">◉</a></div></div><div class="weather-atlas-body"><div class="current_temp"><i class="wi wi-fw wi-weather-30"></i><span class="temp">48°</span><div class="current_text">Partly Cloudy</div><div class="sunrise_sunset">6:42am<i class="wi wi-fw wi-weather-32"></i>7:42pm PDT</div></div><span class="current_text_2">Feels like: 45<small>°F</small><br />Wind: 6<small>mph</small> S<br />Humidity: 75<small>%</small><br />Pressure: 30.13<small>&#34;Hg</small><br />UV index: 1</span><div class="hourly hours" style="border-bottom:1px solid #558822"><span class="extended_hour extended_hour_1">11<small>h</small></span><span class="extended_hour extended_hour_2">12<small>h</small></span></div><div class="hourly"><span class="extended_hour extended_hour_1" title="Partly Cloudy">52<small>°F</small><br /><i class="wi wi-fw wi-weather-30"></i></span><span class="extended_hour extended_hour_2" title="Mostly Cloudy">54<small>°F</small><br /><i class="wi wi-fw wi-weather-28"></i></span></div><div class="daily days" style="border-bottom:1px solid #558822"><span class="extended_day extended_day_1">Sun</span><span class="extended_day extended_day_2">Mon</span><span class="extended_day extended_day_3">Tue</span><span class="extended_day extended_day_4">Wed</span></div><div class="daily"><span class="extended_day extended_day_1" title="Showers">46/34<small>°F</small><br /><i class="wi wi-fw wi-weather-11"></i></span><span class="extended_day extended_day_2" title="Partly Cloudy">55/36<small>°F</small><br /><i class="wi wi-fw wi-weather-30"></i></span><span class="extended_day extended_day_3" title="Partly Cloudy">57/39<small>°F</small><br /><i class="wi wi-fw wi-weather-30"></i></span><span class="extended_day extended_day_4" title="Showers">50/41<small>°F</small><br /><i class="wi wi-fw wi-weather-11"></i></span></div></div><div class="weather-atlas-footer" style="border-top:1px solid #558822"><a href="https://www.weather-us.com/en/washington-usa/burien" title="Weather Atlas - Weather forecast Burien, Washington" style="color:#fff;" target="_blank">Weather forecast <span class="weather-atlas-footer-block">Burien, Washington ▸</span></a></div></div></div> <div id="text-4" class="et_pb_widget widget_text"><h4 class="widgettitle">WEATHER SPONSORED BY</h4> <div class="textwidget"><p></p><center><a href="https://www.seahurstsmiles.com" target="_blank" rel="noopener"><br />
<img src="https://b-townblog.com/wp-content/uploads/2019/10/WeatherSponsorSeahurstSmiles300b.jpg" alt="seahurstsmiles" width="300" height="93" border="0" /></a></center><p></p>
</div>
</div> <div id="custom_html-10" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"> </h4><div class="textwidget custom-html-widget"><center><broadstreet-zone zone-id="72559"></broadstreet-zone></center></div></div> <div id="custom_html-9" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"> </h4><div class="textwidget custom-html-widget"><center><broadstreet-zone zone-id="76016"></broadstreet-zone></center></div></div> <div id="custom_html-8" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"> </h4><div class="textwidget custom-html-widget"><center><broadstreet-zone zone-id="77427"></broadstreet-zone></center></div></div> <div id="custom_html-7" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"> </h4><div class="textwidget custom-html-widget"><center><broadstreet-zone zone-id="72544"></broadstreet-zone></center></div></div> <div id="tribe-events-list-widget-2" class="et_pb_widget tribe-events-list-widget"><h4 class="widgettitle">Upcoming Events</h4>
<ol class="tribe-list-widget">
<li class="tribe-events-list-widget-events type-tribe_events post-150481 tribe-clearfix tribe-events-venue-146742 tribe-events-organizer-148942">

<h4 class="tribe-event-title">
<a href="https://b-townblog.com/event/vanya-and-sonia-and-masha-and-spike-continues-at-bat-theatre-2/" rel="bookmark">‘Vanya And Sonia And Masha And Spike’ continues at BAT Theatre</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">April 3 @ 8:00 pm</span> - <span class="tribe-event-time">9:00 pm</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-150482 tribe-clearfix tribe-events-venue-146742 tribe-events-organizer-148942">

<h4 class="tribe-event-title">
<a href="https://b-townblog.com/event/vanya-and-sonia-and-masha-and-spike-finale-is-sunday-april-4-at-bat-theatre/" rel="bookmark">‘Vanya And Sonia And Masha And Spike’ finalé is Sunday, April 4 at BAT Theatre</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">April 4 @ 2:00 pm</span> - <span class="tribe-event-time">3:00 pm</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-150645 tribe-clearfix tribe-events-venue-146742">

<h4 class="tribe-event-title">
<a href="https://b-townblog.com/event/join-executive-dow-constantine-for-his-hometown-kickoff-on-wednesday-april-7/" rel="bookmark">Join Executive Dow Constantine for his Hometown Kickoff on Wednesday, April 7</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">April 7 @ 5:30 pm</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-149649 tribe-clearfix tribe-events-organizer-137427">

<h4 class="tribe-event-title">
<a href="https://b-townblog.com/event/dog-biscuit-crawl-for-burien-cares-will-be-saturday-april-17/" rel="bookmark">‘Dog Biscuit Crawl’ for Burien CARES will be Saturday, April 17</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">April 17</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-150554 tribe-clearfix tribe-events-venue-146742 tribe-events-organizer-150555">

<h4 class="tribe-event-title">
<a href="https://b-townblog.com/event/master-gardener-2021-online-plant-sale-will-run-from-april-21-27/" rel="bookmark">Master Gardener 2021 Online Plant Sale will run from April 21–27</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">April 21 @ 12:00 pm</span> - <span class="tribe-event-date-end">April 27 @ 6:00 pm</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-150478 tribe-clearfix tribe-events-venue-146742 tribe-events-organizer-148588">

<h4 class="tribe-event-title">
<a href="https://b-townblog.com/event/virtual-event-to-help-launch-maritime-high-school-will-be-thursday-april-22/" rel="bookmark">Virtual event to help launch Maritime High School will be Thursday, April 22</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">April 22 @ 5:30 pm</span> - <span class="tribe-event-time">6:30 pm</span> </div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-149634 tribe-clearfix tribe-events-venue-136291 tribe-events-organizer-137427">

<h4 class="tribe-event-title">
<a href="https://b-townblog.com/event/discover-buriens-clean-sweep-will-be-saturday-april-24/" rel="bookmark">Volunteers needed for Discover Burien’s ‘Clean Sweep’ on Saturday, April 24</a>
</h4>

<div class="tribe-event-duration">
<span class="tribe-event-date-start">April 24 @ 8:00 am</span> - <span class="tribe-event-time">12:00 pm</span> </div>
</li>
</ol>
<p class="tribe-events-widget-link">
<a href="https://b-townblog.com/events/" rel="bookmark">View All Events</a>
</p>
</div> <script type="application/ld+json">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</script><div id="custom_html-13" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"> </h4><div class="textwidget custom-html-widget"><center><broadstreet-zone zone-id="76001"></broadstreet-zone></center></div></div> <div id="custom_html-12" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"> </h4><div class="textwidget custom-html-widget"><center><broadstreet-zone zone-id="76116"></broadstreet-zone></center></div></div> <div id="custom_html-11" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"> </h4><div class="textwidget custom-html-widget"></div></div> <div id="text-7" class="et_pb_widget widget_text"><h4 class="widgettitle">Story Idea or News Tip?</h4> <div class="textwidget"><p></p><center>Send story ideas &amp; tips to us at<br />
<a href="/cdn-cgi/l/email-protection#c5a0a1acb1aab785a7e8b1aab2aba7a9aaa2eba6aaa8"><strong><span class="__cf_email__" data-cfemail="2540414c514a57654708514a524b47494a420b464a48">[email&#160;protected]</span></strong></a>.<p></p>
<p>You can also text us or leave a voicemail 24/7 at <strong>(206) 659-1282</strong>, or call our office at <strong>(206) 248-2565</strong>.</p></center><p></p>
</div>
</div> <div id="text-9" class="et_pb_widget widget_text"><h4 class="widgettitle">Subscribe to our Newsletter</h4> <div class="textwidget"><p>
<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css" />
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; width:100%;}
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
</p><div id="mc_embed_signup">
<form action="https://southkingmedia.us10.list-manage.com/subscribe/post?u=2111f5e0753236f41d3b0f5ae&amp;id=af702f1850" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate="">
<div id="mc_embed_signup_scroll">
<label for="mce-EMAIL">Subscribe to our FREE 6pm Daily Digest Newsletter</label><br />
<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required="" /><br />
<p></p>
<div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_2111f5e0753236f41d3b0f5ae_af702f1850" tabindex="-1" value="" /></div>
<div class="black"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button" /></div>
<p></p></div>
</form>
</div>
<p></p>
</div>
</div> <div id="custom_html-14" class="widget_text et_pb_widget widget_custom_html"><h4 class="widgettitle"> </h4><div class="textwidget custom-html-widget"><center><broadstreet-zone zone-id="72580"></broadstreet-zone></center></div></div> </div>
</div> 
</div> 
</div> 
<footer class="et-l et-l--footer">
<div class="et_builder_inner_content et_pb_gutters4"><div class="et_pb_with_border et_pb_section et_pb_section_0_tb_footer et_pb_with_background et_section_regular">
<div class="et_pb_row et_pb_row_0_tb_footer">
<div class="et_pb_column et_pb_column_1_4 et_pb_column_0_tb_footer  et_pb_css_mix_blend_mode_passthrough">
<div class="et_pb_module et_pb_image et_pb_image_0_tb_footer">
<span class="et_pb_image_wrap "><img src="https://b-townblog.com/wp-content/uploads/2020/05/btown_logoSKM20d.png" alt="" title="btown_logoSKM20d" height="auto" width="auto" class="wp-image-146891" /></span>
</div><div class="et_pb_module et_pb_text et_pb_text_0_tb_footer  et_pb_text_align_left et_pb_bg_layout_dark">
<div class="et_pb_text_inner"><p>The B-Town Blog is Burien’s multiple award-winning hyperlocal news/events website dedicated to independent journalism.</p></div>
</div> <ul class="et_pb_module et_pb_social_media_follow et_pb_social_media_follow_0_tb_footer clearfix  et_pb_text_align_left et_pb_bg_layout_light">
<li class="et_pb_social_media_follow_network_0_tb_footer et_pb_social_icon et_pb_social_network_link  et-social-facebook et_pb_social_media_follow_network_0_tb_footer"><a href="https://www.facebook.com/btownblog/" class="icon et_pb_with_border" title="Follow on Facebook" target="_blank"><span class="et_pb_social_media_follow_network_name" aria-hidden="true">Follow</span></a></li><li class="et_pb_social_media_follow_network_1_tb_footer et_pb_social_icon et_pb_social_network_link  et-social-twitter et_pb_social_media_follow_network_1_tb_footer"><a href="https://twitter.com/btownblog" class="icon et_pb_with_border" title="Follow on Twitter" target="_blank"><span class="et_pb_social_media_follow_network_name" aria-hidden="true">Follow</span></a></li><li class="et_pb_social_media_follow_network_2_tb_footer et_pb_social_icon et_pb_social_network_link  et-social-instagram et_pb_social_media_follow_network_2_tb_footer"><a href="https://instagram.com/btownblog" class="icon et_pb_with_border" title="Follow on Instagram" target="_blank"><span class="et_pb_social_media_follow_network_name" aria-hidden="true">Follow</span></a></li>
</ul> 
</div> <div class="et_pb_column et_pb_column_1_4 et_pb_column_1_tb_footer  et_pb_css_mix_blend_mode_passthrough">
<div class="et_pb_module et_pb_text et_pb_text_1_tb_footer et_clickable  et_pb_text_align_left et_pb_bg_layout_dark">
<div class="et_pb_text_inner"><h4>Quick Links</h4>
<ul>
<li><a href="https://b-townblog.com/advertise/">Advertise</a></li>
<li><a href="https://b-townblog.com/how-to-submit-to-the-blog/">How to Submit</a></li>
<li><a href="https://b-townblog.com/privacy-policy-terms-of-service/">Privacy Policy</a></li><a href="https://b-townblog.com/privacy-policy-terms-of-service/">
</a><p><a href="https://b-townblog.com/privacy-policy-terms-of-service/"></a></p>
<li>
</li><li><a href="https://b-townblog.com/about/">About Us</a></li>
<li><a href="https://b-townblog.com/contact/">Contact Us</a></li>
</ul></div>
</div> 
</div> <div class="et_pb_column et_pb_column_1_2 et_pb_column_2_tb_footer  et_pb_css_mix_blend_mode_passthrough et-last-child et_pb_column_empty">
</div> 
</div> <div class="et_pb_row et_pb_row_1_tb_footer">
<div class="et_pb_column et_pb_column_4_4 et_pb_column_3_tb_footer  et_pb_css_mix_blend_mode_passthrough et-last-child">
<div class="et_pb_module et_pb_text et_pb_text_2_tb_footer  et_pb_text_align_left et_pb_bg_layout_dark">
<div class="et_pb_text_inner">©2021 <a href="https://www.southkingmedia.com/">South King Media</a><span> | Powered by South King Media | <a href="https://btownblogstage.wpengine.com/privacy-policy-2/">Privacy Policy &amp; Terms</a></span></div>
</div> 
</div> 
</div> 
</div>  </div>
</footer>
</div>
</div> 
<span title="Back To Top" id="back_to_top"></span>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-cfasync="false">window.broadstreetKeywords = ['not_home_page','not_landing_page','is_article_page','burien','burien-news-2','events','featured-post','health-wellness','news','sports','springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4','post']</script>
<script data-cfasync="false">window.broadstreetTargets = {"pagetype":["post","not_home_page"],"category":["burien","burien-news-2","events","featured-post","health-wellness","news","sports","springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4","post"],"url":"springtime-walk-n-talk-on-the-indian-trail-this-sunday-april-4"};</script>
<script data-cfasync="false">
window.broadstreet = window.broadstreet || { run: [] };window.broadstreet.run.push(function () {
window.broadstreet.loadNetworkJS(6233);
 });</script> <script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
<script type="text/javascript">
				var et_link_options_data = [{"class":"et_pb_text_1_tb_footer","url":"https:\/\/b-townblog.com\/privacy-policy-terms-of-service\/","target":"_self"}];
			</script>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-W3XBHN9" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<link rel="stylesheet" id="tribe-events-custom-jquery-styles-css" href="https://b-townblog.com/wp-content/plugins/the-events-calendar/vendor/jquery/smoothness/jquery-ui-1.8.23.custom.css?ver=5.5.0" type="text/css" media="all" />
<link rel="stylesheet" id="tribe-events-bootstrap-datepicker-css-css" href="https://b-townblog.com/wp-content/plugins/the-events-calendar/vendor/bootstrap-datepicker/css/bootstrap-datepicker.standalone.min.css?ver=5.5.0" type="text/css" media="all" />
<link rel="stylesheet" id="tribe-events-calendar-style-css" href="https://b-townblog.com/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-full.min.css?ver=5.5.0" type="text/css" media="all" />
<script type="text/javascript" id="pushengage-core-js-before">
window._peq = window._peq || []; window._peq.push(['init']);
</script>
<script type="text/javascript" async="" src="https://clientcdn.pushengage.com/core/49c8cebc-8ec8-4d2c-8119-b6008367.js?ver=5.7" id="pushengage-core-js"></script>
<script type="text/javascript" src="https://b-townblog.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1" id="jquery-ui-core-js"></script>
<script type="text/javascript" src="https://b-townblog.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.12.1" id="jquery-ui-menu-js"></script>
<script type="text/javascript" src="https://b-townblog.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4" id="wp-polyfill-js"></script>
<script type="text/javascript" id="wp-polyfill-js-after">
( 'fetch' in window ) || document.write( '<script src="https://b-townblog.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://b-townblog.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://b-townblog.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://b-townblog.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://b-townblog.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://b-townblog.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );( 'objectFit' in document.documentElement.style ) || document.write( '<script src="https://b-townblog.com/wp-includes/js/dist/vendor/wp-polyfill-object-fit.min.js?ver=2.3.4"></scr' + 'ipt>' );
</script>
<script type="text/javascript" src="https://b-townblog.com/wp-includes/js/dist/dom-ready.min.js?ver=eb19f7980f0268577acb5c2da5457de3" id="wp-dom-ready-js"></script>
<script type="text/javascript" src="https://b-townblog.com/wp-includes/js/dist/hooks.min.js?ver=50e23bed88bcb9e6e14023e9961698c1" id="wp-hooks-js"></script>
<script type="text/javascript" src="https://b-townblog.com/wp-includes/js/dist/i18n.min.js?ver=db9a9a37da262883343e941c3731bc67" id="wp-i18n-js"></script>
<script type="text/javascript" id="wp-i18n-js-after">
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type="text/javascript" id="wp-a11y-js-translations">
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type="text/javascript" src="https://b-townblog.com/wp-includes/js/dist/a11y.min.js?ver=5e00de7a43b31bbb9eaf685f089a3903" id="wp-a11y-js"></script>
<script type="text/javascript" id="jquery-ui-autocomplete-js-extra">
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type="text/javascript" src="https://b-townblog.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.12.1" id="jquery-ui-autocomplete-js"></script>
<script type="text/javascript" id="rocket-browser-checker-js-after">
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type="text/javascript" id="rocket-delay-js-js-after">
(function() {
"use strict";var e=function(){function n(e,t){for(var r=0;r<t.length;r++){var n=t[r];n.enumerable=n.enumerable||!1,n.configurable=!0,"value"in n&&(n.writable=!0),Object.defineProperty(e,n.key,n)}}return function(e,t,r){return t&&n(e.prototype,t),r&&n(e,r),e}}();function n(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function r(e,t){n(this,r),this.attrName="data-rocketlazyloadscript",this.browser=t,this.options=this.browser.options,this.triggerEvents=e,this.userEventListener=this.triggerListener.bind(this)}return e(r,[{key:"init",value:function(){this._addEventListener(this)}},{key:"reset",value:function(){this._removeEventListener(this)}},{key:"_addEventListener",value:function(t){this.triggerEvents.forEach(function(e){return window.addEventListener(e,t.userEventListener,t.options)})}},{key:"_removeEventListener",value:function(t){this.triggerEvents.forEach(function(e){return window.removeEventListener(e,t.userEventListener,t.options)})}},{key:"_loadScriptSrc",value:function(){var r=this,e=document.querySelectorAll("script["+this.attrName+"]");0!==e.length&&Array.prototype.slice.call(e).forEach(function(e){var t=e.getAttribute(r.attrName);e.setAttribute("src",t),e.removeAttribute(r.attrName)}),this.reset()}},{key:"triggerListener",value:function(){this._loadScriptSrc(),this._removeEventListener(this)}}],[{key:"run",value:function(){RocketBrowserCompatibilityChecker&&new r(["keydown","mouseover","touchmove","touchstart","wheel"],new RocketBrowserCompatibilityChecker({passive:!0})).init()}}]),r}();t.run();
}());
</script>
<script type="text/javascript" id="rocket-preload-links-js-extra">
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/wp-login.php","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/b-townblog.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type="text/javascript" id="rocket-preload-links-js-after">
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type="text/javascript" src="https://b-townblog.com/wp-includes/js/masonry.min.js?ver=4.2.2" id="masonry-js"></script>
<script type="text/javascript" id="extra-scripts-js-extra">
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/b-townblog.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/b-townblog.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"7b20ca3672","timeline_nonce":"041a91d9eb","blog_feed_nonce":"e72aa063fd","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"yes"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/b-townblog.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/b-townblog.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/b-townblog.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"1534108803","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"50fb7b0f38","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","wrong_checkbox":"Checkbox","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","ab_tests":[],"is_ab_testing_active":"","page_id":"150657","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"yes","is_shortcode_tracking":"","tinymce_uri":""}; var et_builder_utils_params = {"condition":{"diviTheme":false,"extraTheme":true},"scrollLocations":["app","top"],"builderScrollLocations":{"desktop":"app","tablet":"app","phone":"app"},"onloadScrollLocation":"app","builderType":"fe"}; var et_frontend_scripts = {"builderCssContainerPrefix":"#et-boc","builderCssLayoutPrefix":"#et-boc .et-l"};
var et_pb_box_shadow_elements = [];
var et_pb_motion_elements = {"desktop":[],"tablet":[],"phone":[]};
var et_pb_sticky_elements = [];
/* ]]> */
</script>
<script type="text/javascript" src="https://b-townblog.com/wp-content/themes/Extra/scripts/scripts.unified.js?ver=4.9.3" id="extra-scripts-js"></script>
<script type="text/javascript" src="https://b-townblog.com/wp-content/themes/Extra/core/admin/js/common.js?ver=4.9.3" id="et-core-common-js"></script>
<script type="text/javascript" src="https://trinitymedia.ai/player/trinity.php?viewkey=696d3ce5ae748ca83d700f83c27748e8&amp;postHash=cb83c159fc857742c0ad2de80c14999e&amp;poweredby=1&amp;language=en-US&amp;voiceGender=f&amp;ver=5.7" id="trinity-player-js"></script>
<style id="et-core-unified-tb-144424-tb-144455-150657-cached-inline-styles">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</style><script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async="" src="https://b-townblog.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img loading="lazy" data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.src)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),e.setAttribute("allow", "accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.setAttribute("data-src", a[t].dataset.src),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script>
<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>
<script>var _audins_dom="b_townblog_com",_audins_did=145975;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=194-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.b_townblog_com,DomainId.145975" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script><script type="text/javascript">(function(){window['__CF$cv$params']={r:'63a4e08e89f2c189',m:'76b684f57172ffd50cd8a560142de320dee56921-1617479964-1800-AX9mHoUMEc1crB9S9fJlaPKQGu0sbitYWYu0Ds0XvODrD9z3c0vZSjrznUdFVl+c7dLFf0sL5/dGVZrumwuZNX/cKe2miTh1jCNhbvMoEEEKEiihGKazUYzruS6RBZnreS1Tyn+HxankxzoRouW8Jh8KcGGBlX4+HmP8Ps1hyCtYPBBek1F9+mwcopClrAoSu9UVSVQNJ7fxuljPWpCs5So=',s:[0x5b65273f01,0x0067ecf100],}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"si":10,"rayId":"63a4e08e89f2c189","version":"2021.3.0"}'></script>
</body></html>